• September 22, 2020, 11:33:48 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: RingCentral on a Nortel 1120e  (Read 2291 times)

0 Members and 1 Guest are viewing this topic.

Offline cruiz000

  • Rookie
  • **
  • Posts: 1
RingCentral on a Nortel 1120e
« on: November 18, 2014, 03:27:31 PM »
Good afternoon all,

I feel that I've spent TOO much time trying to figure this out, so I'm releasing my questions on the masses.

I've successfully converted a 1120e to a SIP phone and have gotten it to the point where it can receive calls, but it cannot make calls, nor does the MWI work. I have a feeling that the root of my issue is that my provider (RingCentral) uses separate addresses and ports for their SIP Registrar and Outgoing Proxy.

The SIP Registrar should be sip .ringcentral .com:5060 and the outgoing proxy should be sip10 .ringcentral .com:5090.

Also, my SIP URI does not match my phone number and the SIP URI is what appears on the display. Is there any way to have the phone number appear instead. (I suppose this may also be a function of what's not working.)

I appreciate any help anyone can lend. I have enough grey hair as it is :)

Thanks,
Chuck

Here's the device specific config file:

DNS_DOMAIN sip .ringcentral .com
SIP_DOMAIN1 sip10 .ringcentra l.com
SERVER_IP1_1 199 .255 .120 .176
SERVER_PORT1_1 5090
SERVER_RETRIES1 3
DEF_USER2 1234567890 (Changed to protect the innocent)
VMAIL 5090
VMAIL_DELAY 300
FORCE_BANNER YES
BANNER Front Desk
DEF_LANG English
DEF_AUDIO_QUALITY High
ENABLE_LLDP YES
ADMIN_PASSWORD 26567*738
ADMIN_PASSWORD_EXPIRY 0
# Settings to disable extended license
MAX_LOGINS 1
USB_HEADSET LOCK
EXP_MODULE_ENABLE NO
ENABLE_SERVICE_PACKAGE NO
IM_MODE DISABLED
AVAYA_AUTOMATIC_QoS NO
VQMON_PUBLISH NO
SIP_TLS_PORT 0
ENABLE_BT NO
# Enable SSH
SSH YES
SSHID admin
SSHPWD admin

AUTOLOGIN_ENABLE USE_AUTOLOGIN_ID
PROMPT_AUTHNAME_ENABLE NO
AUTOLOGIN_ID_KEY01 1234567890@sip10 .ringcentral .com (Changed to protect the innocent)
AUTOLOGIN_AUTHID_KEY01 SexyAuthID (Changed to protect the innocent)
AUTOLOGIN_PASSWD_KEY01 SexyPassword (Changed to protect the innocent)