• November 29, 2020, 05:10:38 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: Voice Vlan Problem  (Read 5176 times)

0 Members and 1 Guest are viewing this topic.

Offline kashifkamal

  • Rookie
  • **
  • Posts: 1
Voice Vlan Problem
« on: October 25, 2014, 02:39:07 PM »

Hello everybody I am new to avaya switches and I have to configure Voice vlan. I have avaya ip office 500 connected to port 1 of Avaya 4500 switch and PC's are connected to phones. Now I have Data VLAN DHCP on Microsoft server and Voice vlan DHCP on the pbx below are my configurations. The problem the phones are not working but users are able to get IP from server

vlan create 2 name "Users" type port
vlan members add 2 1-48


vlan create 43 name "Voice" type port voice-vlan
vlan members add 2 1-48


interface fastethernet 49,50
lacp mode active
lacp aggregation enable



vlan create 2,100 type port 1
vlan create 43 type port 1 voice-vlan
vlan name 2 "users"
vlan name 43 "Voice"
vlan name 100 "Management"
vlan ports 49-50 tagging tagAll
vlan configcontrol flexible
vlan members 2,43 ALL
vlan ports ALL pvid 2
no auto-pvid


Offline Flintstone

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 961
Re: Voice Vlan Problem
« Reply #1 on: October 27, 2014, 05:10:33 AM »
Hi kashifkamal and welcome to the forum,

If memory serves me correct.  The Data Vlan is untagged (I.e. PVID is untagged) and the Voice Vlan is tagged.  The DHCP server in the Data Vlan tells the phone to use the tagged Voice Vlan.  The phone then reboots into the Voice Vlan and then gets it IP address etc on that Vlan.

CheerZ

Offline bwilliams2

  • Full Member
  • ***
  • Posts: 58
Re: Voice Vlan Problem
« Reply #2 on: October 31, 2014, 12:19:03 PM »
We set the voice vlan in the config of each phone.

Offline Flintstone

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 961
Re: Voice Vlan Problem
« Reply #3 on: October 31, 2014, 12:28:21 PM »
Hi kashifkamal,

Ok, so you manually configure the Voice Vlan on the IP Phone, which corresponds with the tagged Vlan on the switch.  If that is the case then your DHCP server needs to be configured on that scope/vlan with the appropriate option to provide the signalling server details etc?

CheerZ

Offline Théo

  • Jr. Member
  • **
  • Posts: 34
Re: Voice Vlan Problem
« Reply #4 on: November 03, 2014, 03:18:53 AM »
Hi kashifkamal,

As you need a tagged vlan (voice) and an untagged vlan (data) on the same port, you need to configure access port in UntagPvidOnly or in TagPvidOnly.
With UntagPvidOnly your Pvid must be Data vlan (2)
With TagpvidOnly you Pvid must be Voice vlan (43).
Commands lines are below :
vlan port <ports liste> tagging <UntagPvidOnly | TagPvidOnly>
vlan members add 2,43 <ports liste>
vlan port <ports liste> pvid <vlan-id>

regards,

Théo
ACIS 6103 - ACSS 3605

Offline aGeftwGER

  • Full Member
  • ***
  • Posts: 78
Re: Voice Vlan Problem
« Reply #5 on: November 07, 2014, 05:09:59 AM »
Hi, you can configure the voice vlan for lldp to autoconfigure the phones with callserver, httpserver(fileserver) and auto tagging for the phones:

exactly you should configure the ports to UntagPvidOnly and add both vlans to the port.

lldp vendor-specific avaya call-server 1 x.x.x.x (Registrar of your IPO500)
lldp vendor-specific avaya file-server 1 x.x.x.x (Fileserver of your IPO500)
interface FastEthernet 1-24 (your port list)
lldp port ALL vendor-specific avaya dot1q-framing tagged
exit
interface FastEthernet 1-24 (your port list)
lldp med-network-policies port ALL voice dscp 46 priority 6 tagging tagged vlan-id xx (your voice vlan id)
lldp med-network-policies port ALL voice-signaling dscp 34 priority 6 tagging tagged vlan-id xx (your voice vlan id)
exit
qos if-group name qosTrustedIfcs class trusted
qos if-assign port ALL name qosTrustedIfcs
interface FastEthernet 1-24 (your port list)
spanning-tree port ALL learning fast
exit

Offline takst3r

  • Rookie
  • **
  • Posts: 2
Re: Voice Vlan Problem
« Reply #6 on: November 19, 2014, 06:51:30 AM »
hi  kashifkamal,

Im also new to this switch. Would like to know if you came right with the provisioning with the phones and pc's.
Are they getting the right IP's in the right Vlans,.

If so could you please post me a copy of the config  ;D