• December 02, 2020, 04:48:17 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: VLAN and DHCP Relay  (Read 2028 times)

0 Members and 1 Guest are viewing this topic.

Offline RegularDude

  • Rookie
  • **
  • Posts: 2
VLAN and DHCP Relay
« on: July 28, 2015, 03:54:18 PM »
Hello All,
Another newbie here so please whip me as necessary. :-) Also thanks in advance for any help.

I am trying to setup two 5510-48t switches version 6.3.4.028 with VLAN 1 and VLAN 200 trunked between the two switches with DHCP relay for VLAN 200. It seems I have this working but if I default the two switches and then use telnet and paste in my configurations, I have to reload the switches before my DHCP relay will work. I have included the two switch configurations below. If anyone sees anything else I should do, please let me know.

!*******************************************************
! Test Switch 1
! ******************************************************
enable
configure terminal

sntp server primary address 10.0.0.254
sntp enable

cli password telnet local
username "RO" "PA55w0rd!123" ro
username "RW" "PA55w0rd!456" rw

snmp-server contact "Administrator"
snmp-server name "TestSwitch1"
snmp-server location "Test Location1"

ip default-gateway 10.0.0.254
ip address stack 0.0.0.0
ip address switch 10.0.0.101
ip address netmask 255.255.0.0

spanning-tree port-mode auto

vlan create 200 type port 1
vlan name 1 "10-0-0-0/16"
vlan name 200 "192-168-200-0/24"
vlan ports 47 tagging tagAll
vlan configcontrol flexible
vlan members 1 2,4-48
vlan members 200 1,3,47
vlan ports 1,3 pvid 200
vlan configcontrol autopvid

interface FastEthernet ALL
rate-limit port 1/ALL both 5
exit

clock summer-time EDT date 8 March 2015 02:00 1 November 2015 02:00 60
clock time-zone EST -4 0
clock summer-time recurring 1 Sunday March 02:00 1 Sunday November 02:00 1

ip routing

interface vlan 200
ip address 192.168.200.254 255.255.255.0 2
exit

ip route 0.0.0.0 0.0.0.0 10.0.0.254 10

ip dhcp-relay fwd-path 192.168.200.254 10.0.1.2
interface vlan 200
ip dhcp-relay mode dhcp
Exit

router ospf
router-id 199.127.32.0
exit

!*******************************************************
! Test Switch 2
! ******************************************************
enable
configure terminal

sntp server primary address 10.0.0.254
sntp enable

cli password telnet local
username "RO" "PA55w0rd!123" ro
username "RW" "PA55w0rd!456" rw

snmp-server contact "Administrator"
snmp-server name "TestSwitch2"
snmp-server location "Test Location2"

ip default-gateway 10.0.0.254
ip address stack 0.0.0.0
ip address switch 10.0.0.102
ip address netmask 255.255.0.0

spanning-tree port-mode auto

vlan create 200 type port 1
vlan name 1 "10-0-0-0/16"
vlan name 200 "192-168-200-0/24"
vlan ports 47 tagging tagAll
vlan configcontrol flexible
vlan members 1 2,4-48
vlan members 200 1,3,47
vlan ports 1,3 pvid 200
vlan configcontrol autopvid

interface FastEthernet ALL
rate-limit port 1/ALL both 5
exit

clock summer-time EDT date 8 March 2015 02:00 1 November 2015 02:00 60
clock time-zone EST -4 0
clock summer-time recurring 1 Sunday March 02:00 1 Sunday November 02:00 1

interface vlan 200
ip address 192.168.200.253 255.255.255.0 2
exit

ip route 0.0.0.0 0.0.0.0 10.0.0.254 10
ip dhcp-relay fwd-path 192.168.200.253 10.0.1.2
interface vlan 200
ip dhcp-relay  mode dhcp
exit

router ospf
router-id 232.40.96.0
exit


Offline Dominik

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1564
    • Networkautobahn
Re: VLAN and DHCP Relay
« Reply #1 on: July 29, 2015, 03:18:39 AM »
On default the ERS5k is in L2 mode.
To set the router in L3 you apply the command:
ip routing
That requieres a reboot of the switch to take effect.

Cheers
Itīs always the networks fault!
networkautobahn.com

Offline RegularDude

  • Rookie
  • **
  • Posts: 2
Re: VLAN and DHCP Relay
« Reply #2 on: July 29, 2015, 11:21:43 AM »
Thanks for your response Dominik.

Unless I am not understanding, I don't see the same behavior.

After defaulting the switch and after I paste in the new configuration, if I manually configure IP settings on a PC attached to VLAN 200 it will route correctly. I can even telnet into the router and turn routing off and on again without a reboot of the switch.

Now I have found that if I type the entire configuration into the switch instead of paste it, it works correctly without a reboot. Knowing this, I'm not too worried about this issue.

It seems that only when I paste the configuration is when the DHCP relay process won't work without a reboot.