• September 19, 2020, 02:49:30 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: Trunks Between Nortel 8600 and Cisco Switch not Workin  (Read 3798 times)

0 Members and 1 Guest are viewing this topic.

Offline jeff2679

  • Rookie
  • **
  • Posts: 13
Trunks Between Nortel 8600 and Cisco Switch not Workin
« on: July 17, 2014, 03:47:58 PM »
Hi Guys,
Please help. We deployed a new Cisco switch to connect to a pair of Nortel 8600 and we can only get one link up, the second link will not come up below is a sample of what we configured on both the Nortel and Cisco:

1st Core:
ethernet 1/5 perform-tagging enable
vlan 29 ports add 1/1-1/2,1/5,1/12-1/30 member portmember
vlan 30 ports add 1/1-1/2,1/5,1/15-1/17,1/29-1/30 member portmember
vlan 33 ports add 1/1-1/2,1/5,1/12,1/17,1/20 member portmember
vlan 199 ports add 1/1-1/2,1/5,1/12,1/14,1/17,1/20-1/22,1/24-1/26,1/28 member portmember

ethernet 1/5 untagged-frames-discard enable
ethernet 1/5 default-vlan-id 29
ethernet 1/5 cp-limit enable multicast-limit 1000 broadcast-limit 1000
ethernet 1/5 enable-diffserv true
ethernet 1/5 name "Link to 05"
ethernet 1/5 slpp packet-rx enable
ethernet 1/5 slpp packet-rx-threshold 5
ethernet 1/5 stg 1 stp disable
ethernet 1/5 smlt 146 create
ethernet 1/5 vlacp  macaddress 01:80:c2:00:00:0f
ethernet 1/5 vlacp  fast-periodic-time 500
ethernet 1/5 vlacp  timeout short


2nd Core:

ethernet 1/5 perform-tagging enable
vlan 29 ports add 1/1-1/2,1/5,1/12-1/30 member portmember
vlan 30 ports add 1/1-1/2,1/5,1/15-1/17,1/29-1/30 member portmember
vlan 33 ports add 1/1-1/2,1/5,1/12,1/17,1/20 member portmember
vlan 199 ports add 1/1-1/2,1/5,1/12,1/14,1/17,1/20-1/22,1/24-1/28 member portmember

ethernet 1/5 untagged-frames-discard enable
ethernet 1/5 default-vlan-id 29
ethernet 1/5 cp-limit enable multicast-limit 1000 broadcast-limit 1000
ethernet 1/5 enable-diffserv true
ethernet 1/5 name "Link to 05"
ethernet 1/5 slpp packet-rx enable
ethernet 1/5 slpp packet-rx-threshold 50
ethernet 1/5 stg 1 stp disable
ethernet 1/5 smlt 146 create
ethernet 1/5 vlacp  macaddress 01:80:c2:00:00:0f
ethernet 1/5 vlacp  fast-periodic-time 500
ethernet 1/5 vlacp  timeout short

Cisco Switch:

interface GigabitEthernet1/0/49
 description "To Core1:
 switchport mode trunk
 no cdp enable
 channel-group 1 mode active
end


interface GigabitEthernet1/0/50
 description "To Core2
 switchport mode trunk
 shutdown
 no cdp enable
 channel-group 1 mode active
end

interface Port-channel1
 description "To 1 Cores"
 switchport mode trunk
end

Thank you very much..
« Last Edit: August 13, 2014, 04:00:41 PM by jeff2679 »


Offline Johan Witters

  • Sr. Member
  • ****
  • Posts: 252
    • BKM Networks
Re: Trunks Between Nortel 8600 and Cisco Switch not Workin
« Reply #1 on: July 18, 2014, 08:17:43 AM »
Hi Jeff,

take a look at port 1/0/50 on the Cisco, it is showing the "shutdown" command. This will probably be the issue, unless you configured it for testing etc.

If not, issue the "no shut" command, and the port should come active.


Greetz,


Johan
Kind regards,

Johan Witters

Network Engineer
BKM NV

Offline Paul L

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 754
    • paulaleroux
    • Paul's Networking blog
Re: Trunks Between Nortel 8600 and Cisco Switch not Workin
« Reply #2 on: July 18, 2014, 09:01:23 AM »
dito on the NO SHUT.

as well, I would disable VLACP. 

as a rule, I never use limiting, SLPP, VLACP, or other protection features until everything is up.  Once everything is up and tested I will tighten things up.
ACSS- Avaya Enterprise Routing Switch  #8

Offline jeff2679

  • Rookie
  • **
  • Posts: 13
Re: Trunks Between Nortel 8600 and Cisco Switch not Workin
« Reply #3 on: July 18, 2014, 11:32:31 AM »
Thanks guys the port was shutdown as both links go down the minute we bring the second link up. I have been advised to take off VLACP and use LACP instead..

Offline Paul L

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 754
    • paulaleroux
    • Paul's Networking blog
Re: Trunks Between Nortel 8600 and Cisco Switch not Workin
« Reply #4 on: July 18, 2014, 11:43:41 AM »
VLACP and LACP are completely different things...

I would disable SPT on the Cisco switch.
ACSS- Avaya Enterprise Routing Switch  #8

Offline jeff2679

  • Rookie
  • **
  • Posts: 13
Re: Trunks Between Nortel 8600 and Cisco Switch not Workin
« Reply #5 on: July 18, 2014, 11:59:45 AM »
My understanding is that VLACP is Nortel proprietary and will not work with Cisco. See below:


Virtual Link Aggregation Control Protocol (VLACP)
In an Avaya network there is a special secret sauce that helps to bring everything together providing timely failure detection and recovery in an MLT, DMLT, IST, SMLT and SLT topology. VLACP is a lightweight heartbeat protocol utilized between two Avaya switches to detect Layer 2 connectivity issues between two endpoints. The trick these days isnít detecting a failure but knowing when to restore a failed path taking into account the time it takes to rebuild routing and forward tables. VLACP is an Avaya proprietary protocol so it will only work between two Avaya switches.

Offline jeff2679

  • Rookie
  • **
  • Posts: 13
Re: Trunks Between Nortel 8600 and Cisco Switch not Workin
« Reply #6 on: July 18, 2014, 02:48:49 PM »
Hi Guys for anyone who might need this in the future we finally got this working and below is the script that made this happen:.
On another note I was unable to delete the VLACP config from that interface, if anyone know how please let me know..

Cisco :
interface Port-channel1
description "To Cores"
switchport mode trunk

interface GigabitEthernet1/0/49
description "To "Core1"
switchport mode trunk
no cdp enable
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet1/0/50
description "To Core2
switchport mode trunk
no cdp enable
channel-protocol lacp
channel-group 1 mode active


Both Nortel 8600s:
ethernet 1/5 perform-tagging enable
ethernet 1/5 untagged-frames-discard enable
ethernet 1/5 default-vlan-id 29
ethernet 1/5 cp-limit enable multicast-limit 1000 broadcast-limit 1000
ethernet 1/5 enable-diffserv true
ethernet 1/5 name "Link to Cisco"
ethernet 1/5 slpp packet-rx enable
ethernet 1/5 slpp packet-rx-threshold 5
ethernet 1/5 lacp key 4
ethernet 1/5 lacp aggregation true
ethernet 1/5 lacp enable
ethernet 1/5 vlacp  macaddress 01:80:c2:00:00:0f
ethernet 1/5 vlacp  fast-periodic-time 500
ethernet 1/5 vlacp  timeout short




Cisco#show etherchannel summary


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         LACP      Gi1/0/49(I) Gi1/0/50(I)

Cisco#

Offline jeff2679

  • Rookie
  • **
  • Posts: 13
Re: Trunks Between Nortel 8600 and Cisco Switch not Workin
« Reply #7 on: July 18, 2014, 03:01:13 PM »
Am open to comments to this implementation please..

Offline Johan Witters

  • Sr. Member
  • ****
  • Posts: 252
    • BKM Networks
Re: Trunks Between Nortel 8600 and Cisco Switch not Workin
« Reply #8 on: July 18, 2014, 06:08:06 PM »
Config looks ok. You can't really remove the vlacp settings, but I think that if you change the timeout from short to long, the settings will disappear. But it's no problem as long as you don't enable vlacp on the interface..

Johan
Kind regards,

Johan Witters

Network Engineer
BKM NV