• January 23, 2021, 10:23:34 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: suggestion for configuring LLDP/ADAC on ers 3526+  (Read 8089 times)

0 Members and 1 Guest are viewing this topic.

Offline sepe

  • Rookie
  • **
  • Posts: 11
suggestion for configuring LLDP/ADAC on ers 3526+
« on: June 10, 2013, 06:16:33 AM »
hi,

i am trying to configure adac for my avaya phones...but some how some of the configurations switch is accpeting and some of them not...
i dont know why may be because i am not using it properly..

can some 1 share the configuration for configuring adac/lldp to be configured on switch...
right now i am having one voice vlan(20)...in the switch... and no data vlan as we have no requirement for that...and i have plugged gw/s8300/voice portal over it.....

kindly suggest for avaya phones to work proprly on switch which configuration /protocol shall i use...

and if possible kindly share the configuration for configuring the switch for lldp/adac or any other which u suggest would work...

thanks in advance


Offline Flintstone

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 962
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #1 on: June 10, 2013, 08:59:39 AM »

Offline sepe

  • Rookie
  • **
  • Posts: 11
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #2 on: June 11, 2013, 02:17:23 AM »
hi flinstone,

I tried the config and I was facing this error...
my version is 5.0.0.008      FW 1.0.0.4

3526T-PWR+>enable
3526T-PWR+#config t
Enter configuration commands, one per line.  End with CN                  TL/Z.
3526T-PWR+(config)#vlan configcontrol autopvid
3526T-PWR+(config)#vlan ports 24 tagging enable
3526T-PWR+(config)#vlan ports 24 filter-untagged-frame e                  nable
3526T-PWR+(config)#vlan members remove 1 all
3526T-PWR+(config)#vlan create 200 name "data" type port
3526T-PWR+(config)#vlan members add 200 5
3526T-PWR+(config)#vlan create 10 name "test" type port
3526T-PWR+(config)#vlan members add 10 all
3526T-PWR+(config)#vlan create 11 name "voice" type port                   voice-vlan
                                                                           ^
% Invalid input detected at '^' marker.
3526T-PWR+(config)#vlan create 11 name "voice" type port voice-vlan***why it is giving errorXXXXX
                                                         ^
% Invalid input detected at '^' marker.
3526T-PWR+(config)#show adac
       ADAC Global Configuration
---------------------------------------
ADAC Admin State:  Disabled
ADAC Oper State:  Disabled
Operating Mode:  Untagged Frames Basic
Voice-VLAN ID:  None
Call Server Port:  None
Uplink Port:  None
3526T-PWR+(config)#adac enable

3526T-PWR+(config)#adac voice-vlan 11   *AADDED VLAN here** but not showing in SHOW VLAN below???
3526T-PWR+(config)#show adac
       ADAC Global Configuration
---------------------------------------
ADAC Admin State:  Enabled
ADAC Oper State:  Enabled
Operating Mode:  Untagged Frames Basic
Voice-VLAN ID:  11
Call Server Port:  None
Uplink Port:  None
3526T-PWR+(config)#show vlan
Id   Name                 Type     Protocol         PID     Active IVL/SVL Mgmt
---- -------------------- -------- ---------------- ------- ------ ------- ----
1    VLAN #1              Port     None             0x0000  Yes    IVL     Yes
        Port Members: NONE
10   test                 Port     None             0x0000  Yes    IVL     No
        Port Members: ALL
200  data                 Port     None             0x0000  Yes    IVL     No
        Port Members: 5
Total VLANs: 3.

what can be the possible problem.....or where I am going wrong....



thanks....

Offline sepe

  • Rookie
  • **
  • Posts: 11
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #3 on: June 11, 2013, 02:23:33 AM »
continued


post that when I am trying to config adac op-mode to tagged frames

adac op-mode tagged frames   it is prompting me error...

% cannot modify seettings
% not enough Qos resources available....


and some times even when I try to enable ADAC   

that time also I faces above error.....(% cannot modify seettings
% not enough Qos resources available)

Offline tbigby

  • Full Member
  • ***
  • Posts: 60
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #4 on: June 13, 2013, 09:03:19 PM »
For the voice VLAN issue, create the VLAN as normal:

Code: [Select]
vlan create 11 name "voice" type port
Then set it to the Voice VLAN:

Code: [Select]
vlan voice-vlan 11
Now for the ADAC problem, you are out of 'QoS precedences'. Annoyingly you can't enable ADAC on a 3500 series switch without freeing up a QoS precedence. The one that I usually disable is DHCP Forwarding as I don't use that on my 3500s.

In EDM you can do it via IP - DHCP Relay - untick DHCP Forwarding Enabled.

I'm not sure what the command-line option to do that is but I'm sure there is one.

Once that's disabled, you should be able to enable ADAC.
Tony Bigby

Offline Michael McNamara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3843
    • michaelfmcnamara
    • Michael McNamara
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #5 on: June 18, 2013, 02:51:41 PM »
That software version for the ERS 3500 doesn't support the features of the newer software releases.

In that case you should refer to this older blog post covering the ERS 5520;

http://blog.michaelfmcnamara.com/2007/10/nortel-ers-5520-pwr-switch/

Which follows the information that @tbigby provided you.

Good Luck!
We've been helping network engineers, system administrators and technology professionals since June 2009.
If you've found this site useful or helpful, please help me spread the word. Link to us in your blog or homepage - Thanks!

Offline pat2012

  • Sr. Member
  • ****
  • Posts: 156
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #6 on: November 18, 2013, 03:07:32 PM »
Hi folks.

I'm trying to do the same thing with a 3510 Rel 5.1.1, but I'm encountering the same issue with the precedence when trying to configure ADAC.  Issuing the command no ip dhcp-relay doesn't seem to make a difference.  That's the ACLI command that disables DHCP Forwarding as suggested by tbigby.

I'm I missing something?

Offline tbigby

  • Full Member
  • ***
  • Posts: 60
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #7 on: November 19, 2013, 10:14:08 PM »
Hi pat2012, I'm not sure what the problem is there as I've not upgraded to 5.1.1 yet - still on 5.0.2.

Could you perhaps show us the output from:

Code: [Select]
show ip dhcp-relay
Code: [Select]
show adac
And in 'configure terminal' mode:

Code: [Select]
adac enable
For reference, mine are:

Code: [Select]
****#show ip dhcp-relay
===============================
       DHCP Relay Global
===============================
DHCP relay is disabled
DHCP relay option82 is disabled
DHCP relay max-frame is 576

Code: [Select]
****#show adac
       ADAC Global Configuration
---------------------------------------
ADAC Admin State:  Enabled
ADAC Oper State:  Enabled
Operating Mode:  Tagged Frames
Voice-VLAN ID:  1493
Call Server Port:  None
Uplink Port:  8

I can't of course show the output from 'adac enable' as mine is already enabled!
Tony Bigby

Offline pat2012

  • Sr. Member
  • ****
  • Posts: 156
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #8 on: November 20, 2013, 08:47:09 AM »
Thanks for your reply, Tbigby.

This is a bit embarrassing.  We did a factory reset and now the ADAC configuration seems to be working as documented.  What was happening before is that after I disabled DHCP-RELAY and issued a sho qos diag, I was still seeing the precedences being used by DHCP and enabling ADAC would fail.

Now, since the factory reset and reconfiguration, the disabling of DHCP-RELAY releases the precedence as it should.  ADAC can now be enabled.

Not sure what in the previous config would have caused that behavior.

Thanks again.

Offline tbigby

  • Full Member
  • ***
  • Posts: 60
Re: suggestion for configuring LLDP/ADAC on ers 3526+
« Reply #9 on: November 20, 2013, 05:17:45 PM »
No problem, that's interesting. I wonder if a bug in the upgrade process caused this? I will keep an eye out for it in the future.

Good to hear that you got it working though!
Tony Bigby