• September 19, 2020, 01:57:08 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: SPAN port and 8021q  (Read 1615 times)

0 Members and 1 Guest are viewing this topic.

Offline 1cent1

  • Rookie
  • **
  • Posts: 1
SPAN port and 8021q
« on: January 19, 2015, 03:43:26 PM »
HI,
 i am trying to configure SPAN port in my switch.

i have succeed to configure


Port Mirroring Active for Instance 1
Monitoring Mode   XrxXtxPorts ( Ports <-> )
Monitor Port   Port 7
Mirrored Ports   5-6

i see traffic from port 5 and 6 in port 7. ->Working as expected.


BUT

ON server connected to port 5 using vconfig add (linux server) i have set vlan tag 10
On server connected to port 6 using vconfig add i have set vlan tag 10
Traffic on vlan 10 is passing between 2 server ports (5 and 6) are configured "TAGGED ALL" ->Working as expected.
 

in SPAN port 7 traffic packets are received BUT are not marked with 802.1q... switch configured "TAGGED ALL"

My server on port 7 is configure as bond and has no IP address.

Any  idea ?
thanks

Switch Information
Module Description   Ethernet Routing Switch 5510 slots
Pluggable Port 47   None
Pluggable Port 48   None
Firmware Version   6.0.0.6
Software Version   6.1.0.006
Hardware Version   5510-48T HW:36
« Last Edit: January 19, 2015, 03:45:31 PM by 1cent1 »


Offline tbigby

  • Full Member
  • ***
  • Posts: 60
Re: SPAN port and 8021q
« Reply #1 on: January 20, 2015, 08:21:27 PM »
Hi there, this is probably related to your capture setup, not the switch. Most network cards and drivers will strip the VLAN tags before sending the packets to the capture program.

If you are using Wireshark, check out http://wiki.wireshark.org/CaptureSetup/VLAN.

I think I have once managed to capture VLAN tags on a Windows Wireshark install, but it was painful and I can't remember what settings I used. What you need to do will mostly depend on what type of network card you are capturing from.
Tony Bigby