• September 21, 2020, 08:42:23 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: SNTP: Could not sync to NTP servers  (Read 5254 times)

0 Members and 1 Guest are viewing this topic.

Offline figunet

  • Rookie
  • **
  • Posts: 16
SNTP: Could not sync to NTP servers
« on: March 17, 2014, 02:59:20 AM »
Hello, I have problem witn sntp, switch could not sync to ntp servers.

Config in switch
SNTP Status:                    Enabled
Primary server address:         X.X.X.X
Secondary server address:       0.0.0.0
Sync interval:                  24 hours
Last sync source:               X.X.X.X
Primary server sync failures:   23

communication with sntp server
ping X.X.X.X
Host is reachable

SNTP daemon in server is ok.

Which is it the problem??? ???

Thank you.


Offline Alain

  • Rookie
  • **
  • Posts: 9
Re: SNTP: Could not sync to NTP servers
« Reply #1 on: March 17, 2014, 03:50:47 AM »
Hi,

Did you configure ip manager? <show ipmgr>

Offline figunet

  • Rookie
  • **
  • Posts: 16
Re: SNTP: Could not sync to NTP servers
« Reply #2 on: March 17, 2014, 04:05:29 AM »
Yes

show ipmgr
TELNET Access: Enabled
SNMP Access:   Enabled
WEB Access:    Enabled
TELNET IP List Access Control: Enabled
SNMP IP List Access Control:   Enabled
WEB IP List Access Control:    Enabled
Allowed Source IP Address  Allowed Source Mask
-------------------------  -------------------
1  0.0.0.0                    0.0.0.0

Offline Flintstone

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 961
Re: SNTP: Could not sync to NTP servers
« Reply #3 on: March 17, 2014, 04:44:30 AM »
Hi figunet,

Try using a Sniffer to capture the packets to/from NTP server to see if that can shed any light?

CheerZ

Offline figunet

  • Rookie
  • **
  • Posts: 16
Re: SNTP: Could not sync to NTP servers
« Reply #4 on: March 17, 2014, 05:02:08 AM »
Flintstone,
I put a tcpdump on the server and saw that requests and responses came out and arrived perfectly but switches dint't sync

Offline figunet

  • Rookie
  • **
  • Posts: 16
Re: SNTP: Could not sync to NTP servers
« Reply #5 on: March 17, 2014, 05:05:40 AM »
For example:_

tcpdump host 192.168.253.222
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
10:04:53.037908 IP 192.168.253.222.4401 > 192.168.253.23.ntp: NTPv1, Client, length 48
10:04:53.038049 IP 192.168.253.23.ntp > 192.168.253.222.4401: NTPv1, Server, length 48
10:04:55.037899 IP 192.168.253.222.4402 > 192.168.253.23.ntp: NTPv1, Client, length 48
10:04:55.037992 IP 192.168.253.23.ntp > 192.168.253.222.4402: NTPv1, Server, length 48
10:04:57.037941 IP 192.168.253.222.4403 > 192.168.253.23.ntp: NTPv1, Client, length 48
10:04:57.038044 IP 192.168.253.23.ntp > 192.168.253.222.4403: NTPv1, Server, length 48
10:04:58.047238 ARP, Request who-has 192.168.253.222 tell 192.168.253.23, length 28
10:04:58.048722 ARP, Reply 192.168.253.222 is-at 00:1c:17:c0:74:00 (oui Unknown), length 50
10:04:59.037933 IP 192.168.253.222.4404 > 192.168.253.23.ntp: NTPv1, Client, length 48
10:04:59.038047 IP 192.168.253.23.ntp > 192.168.253.222.4404: NTPv1, Server, length 48


Offline Dominik

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1564
    • Networkautobahn
Re: SNTP: Could not sync to NTP servers
« Reply #6 on: March 17, 2014, 05:12:55 AM »
The SNTP settings are pretty much straight forward, there is not much that you can do wrong.

Try to set the global SNTP state from enable to disable.
Sometimes it works if you enable it again.

Can you provide the Switch and SW with that you have the problem.

THX
Itīs always the networks fault!
networkautobahn.com

Offline figunet

  • Rookie
  • **
  • Posts: 16
Re: SNTP: Could not sync to NTP servers
« Reply #7 on: March 17, 2014, 05:36:36 AM »
The problem is not only with one switch, there are problem with 8 or 10 switch, but others are ok. I probe to disable and enable again and see that it work

Offline Michael McNamara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • michaelfmcnamara
    • Michael McNamara
Re: SNTP: Could not sync to NTP servers
« Reply #8 on: March 17, 2014, 09:22:56 AM »
I would then focus on the NTP server... from another Linux host try the ntpdate x.x.x.x command to see if the NTP server is responding to SNTP requests.
We've been helping network engineers, system administrators and technology professionals since June 2009.
If you've found this site useful or helpful, please help me spread the word. Link to us in your blog or homepage - Thanks!

Offline figunet

  • Rookie
  • **
  • Posts: 16
Re: SNTP: Could not sync to NTP servers
« Reply #9 on: March 17, 2014, 09:56:43 AM »
Hello Michael:

the server is responding to requests made ​​to it from other computers

ntpdate -q 192.168.253.23
server 192.168.253.23, stratum 0, offset 0.000000, delay 0.00000

Offline figunet

  • Rookie
  • **
  • Posts: 16
Re: SNTP: Could not sync to NTP servers
« Reply #10 on: March 18, 2014, 07:43:38 AM »
At the end the problem was with ntp.driftfile, i deleted and regenerated and now it's ok.

Thanks for all.

Offline Dominik

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1564
    • Networkautobahn
Re: SNTP: Could not sync to NTP servers
« Reply #11 on: March 18, 2014, 11:53:02 AM »
Good to hear that it worked out.

Cheers
Itīs always the networks fault!
networkautobahn.com