• February 19, 2018, 03:18:34 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: Passport 8003 to Cisco 2921  (Read 1725 times)

0 Members and 1 Guest are viewing this topic.

Offline joan1971

  • Rookie
  • **
  • Posts: 24
Passport 8003 to Cisco 2921
« on: November 17, 2015, 06:37:03 AM »
Hello,

I am in trouble. I connected my very old passport 8003 switch to a Cisco 2921 router and although the physical link is up, the interface on the router's side is down.

Configuration on the Passport is:

ethernet 2/8 routing disable
ethernet 2/8 auto-negotiate disable
ethernet 2/8 cp-limit disable multicast-limit 15000 broadcast-limit 10000
ethernet 2/8 access-diffserv true
ethernet 2/8 linktrap disable
ethernet 2/8 name "Link to 2921"
ethernet 2/8 qos-level 0
ethernet 2/8 stg 1 stp disable

and on the 2921 is:
 
interface GigabitEthernet0/0/0
 description *** Optic Link to MAN ***
 ip address 172.16.0.1 255.255.0.0
 media-type sfp
end

As you can see I have turned my 8003 interface into an access port (belonging only to the default vlan) and stopped the stp on it. Despite all that, the router interface refuses to go up.

Any ideas would be hugely appreciated!

Thanks,
Joan.


Offline joan1971

  • Rookie
  • **
  • Posts: 24
Re: Passport 8003 to Cisco 2921
« Reply #1 on: November 17, 2015, 06:38:34 AM »
***Sorry if I wrongly posted on the Nortel/Avaya switching thread! I wasn't sure if I should post on the Cisco router thread instead..   :-\ ***

Offline TankII

  • Hero Member
  • *****
  • Posts: 542
Re: Passport 8003 to Cisco 2921
« Reply #2 on: November 17, 2015, 06:42:18 AM »
PVID matches the VLAN ID on the 8003?  If they are not the same, it won't come up past layer-1.

Offline joan1971

  • Rookie
  • **
  • Posts: 24
Re: Passport 8003 to Cisco 2921
« Reply #3 on: November 17, 2015, 06:46:11 AM »
Spanning tree is not running on 2921.

Offline joan1971

  • Rookie
  • **
  • Posts: 24
Re: Passport 8003 to Cisco 2921
« Reply #4 on: November 17, 2015, 07:38:22 AM »
Spanning tree is not running on 2921.

I did this on the 2921:

interface GigabitEthernet0/0/0
 description *** Optic Link to MAN ***
 ip address 172.16.0.1 255.255.0.0
 media-type sfp
 vlan-id dot1q 1
  bridge-group 1

and it won't come up!  :-[


Offline Dominik

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1564
    • Networkautobahn
Re: Passport 8003 to Cisco 2921
« Reply #5 on: November 18, 2015, 08:46:33 AM »
What do try to acomplish with your configuration ?

You have on the Passport8k diabled autoneg and routing disbled.
On the 2921 you have a L3 interface and autoneg enbled ?

Try to enable autoneg on both sides to get up the Link.

Cheers
Itīs always the networks fault!
networkautobahn.com

Offline joan1971

  • Rookie
  • **
  • Posts: 24
Re: Passport 8003 to Cisco 2921
« Reply #6 on: November 18, 2015, 08:56:01 AM »
Thanks for the answer.
With autoneg off, the interface on the passport is up. Once I turn autoneg on, the interface goes down.
I think I have to turn autoneg off on the cisco as well and manually configure speed etc. Would this be ok?

Offline joan1971

  • Rookie
  • **
  • Posts: 24
Re: Passport 8003 to Cisco 2921
« Reply #7 on: November 18, 2015, 09:13:12 AM »
My goal is to connect my passport8k (which is a core switch for a L2 network) to my 2921 router. I don't need to enable L3 routing on the passport. I just want to use the cisco interface as a gateway when I want to access this L2 network from my other networks (mostly) for management purposes).

Offline Dominik

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1564
    • Networkautobahn
Re: Passport 8003 to Cisco 2921
« Reply #8 on: November 18, 2015, 09:13:58 AM »
You need to have the same configuration on both sides.
So if you want to use autoneg enbale it on both sides.
Itīs always the networks fault!
networkautobahn.com

Offline joan1971

  • Rookie
  • **
  • Posts: 24
Re: Passport 8003 to Cisco 2921
« Reply #9 on: November 18, 2015, 09:21:15 AM »
With autoneg on on both sides the link goes down.