• September 19, 2020, 04:59:21 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: Nortel 5510-48T Allowing UPnP Through VLAN's  (Read 2865 times)

0 Members and 1 Guest are viewing this topic.

Offline cuber351

  • Rookie
  • **
  • Posts: 3
Nortel 5510-48T Allowing UPnP Through VLAN's
« on: March 17, 2015, 10:08:32 PM »
HW:05       FW:6.0.0.18  SW:v6.3.3.041
I have pfSense as my edge router and I'm not sure how to go about allowing UPnP throughout my network. The command ip static-mroute sounds promising but it's very possible I'm not using it properly. I don't have a license through Avaya so the advanced features are not available to me.


Here's my running config:
! Embedded ASCII Configuration Generator Script
! Model = Ethernet Routing Switch 5510-48T
! Software version = v6.3.3.041
!
! Displaying only parameters different to default
!================================================
enable
configure terminal
!
! *** CORE ***
!
sntp server primary address 50.241.66.170
sntp server secondary address 108.166.189.70
sntp enable
sntp sync-interval 168

cli password serial local
cli password telnet local
! username "user" "********" ro
! username "admin" "********" rw
tftp-server 172.16.0.10
!
! *** SNMP ***
!
!
! *** IP  ***
!
ip default-gateway 192.168.0.254
ip address stack 0.0.0.0
ip address switch 192.168.0.1
ip address source configured-address
ip name-server 192.168.1.100
ip name-server 192.168.1.32
!
! *** IP Manager ***
!
!
! *** ASSET ID ***
!
!
! *** IPFIX ***
!
!
! *** System Logging ***
!
!
! *** STACK ***
!
!
! *** Default Command Interface ***
!
!
! *** Custom Banner ***
!
banner custom
banner 1 "WARNING: This computer system and network is PRIVATE and PROPRIETARY
and may"
banner 2 "only be accessed by authorized users. Unauthorized use of this comput
er system"
banner 3 "or network is strictly prohibited and may be subject to criminal pros
ecution,"
banner 4 "employee discipline up to and including discharge, or the termination
 of the"
banner 5 "vendor/service contracts. The owner, or its agents, may monitor any a
ctivity"
banner 6 "or communication on the computer system or network."
!
! *** SSH ***
!
ssh
!
! *** SSL ***
!
ssl
!
! *** SSHC ***
!
!
! *** STP (Phase 1) ***
!
spanning-tree port-mode auto
!
! *** VLAN ***
!
vlan create 99-101 type port 1
vlan name 99 "Native VLAN"
vlan name 100 "My LAN Devices"
vlan name 101 "Wireless Devices"
vlan configcontrol flexible
vlan members 1 1
vlan members 99 2-23,25-45,47-48
vlan members 100 46
vlan members 101 24
vlan ports 2-23 pvid 99
vlan ports 24 pvid 101
vlan ports 25-45 pvid 99
vlan ports 46 pvid 100
vlan ports 47-48 pvid 99
no auto-pvid
!
! *** EAP ***
!
!
! *** EAP Guest VLAN ***
!
!
! *** EAP Fail Open VLAN ***
!
!
! *** EAP Voip VLAN ***
!
!
! *** 802.1ab ***
!

!
! *** 802.1ab vendor-specific Avaya TLVs config ***
!
!
! *** 802.1AB MED Voice Network Policies ***
!
!
! *** QOS ***
!
!
! *** RMON ***
!
!
! *** Interface ***
!
!
! *** Rate-Limit ***
!
!
! *** MLT (Phase 1) ***
!
!
! *** MAC-Based Security ***
!
!
! *** LACP ***
!
!
! *** ADAC ***
!
!
! *** STP (Phase 2) ***
!
interface FastEthernet ALL
spanning-tree port 2-48 learning fast
spanning-tree bpdu-filtering port 2-23,25-48 enable
exit
!
! *** Port Mirroring ***
!
!
! *** VLAN Phase 2***
!
!
! *** MLT (Phase 2) ***
!
!
! *** PoE ***
!
!
! *** RTC ***
!
clock time-zone CST -6 0
clock summer-time recurring 2 Sunday March 02:00 1 Sunday November 02:00 60
!
! *** Avaya Energy Saver ***
!
!
! *** AUR ***
!
!
! *** AAUR ***
!
!
! *** L3 ***
!
!
ip routing
!
interface vlan 99
ip address 192.168.1.254 255.255.255.0 2
exit
interface vlan 100
ip address 172.16.0.62 255.255.255.192 3
exit
interface vlan 101
ip address 172.16.1.126 255.255.255.128 4
exit

! --- ECMP ---


! No license for ECMP.
ip route 0.0.0.0 0.0.0.0 192.168.0.254 10
!
! *** Brouter Port ***
!
!
! *** IPV6 ***
!
!
! *** NSNA ***
!
!
! *** VLACP ***
!
!
! *** DHCP Relay ***
!
ip dhcp-relay fwd-path 172.16.0.62 192.168.1.30
ip dhcp-relay fwd-path 172.16.0.62 192.168.1.30 mode dhcp
ip dhcp-relay fwd-path 172.16.0.62 192.168.1.31
ip dhcp-relay fwd-path 172.16.0.62 192.168.1.31 mode dhcp
ip dhcp-relay fwd-path 172.16.0.62 192.168.1.100
ip dhcp-relay fwd-path 172.16.0.62 192.168.1.100 mode dhcp
ip dhcp-relay fwd-path 172.16.1.126 192.168.1.30
ip dhcp-relay fwd-path 172.16.1.126 192.168.1.30 mode dhcp
ip dhcp-relay fwd-path 172.16.1.126 192.168.1.31
ip dhcp-relay fwd-path 172.16.1.126 192.168.1.31 mode dhcp
ip dhcp-relay fwd-path 172.16.1.126 192.168.1.100
ip dhcp-relay fwd-path 172.16.1.126 192.168.1.100 mode dhcp
interface vlan 100
ip dhcp-relay  mode dhcp
ip dhcp-relay broadcast
exit
interface vlan 101
ip dhcp-relay  mode dhcp
ip dhcp-relay broadcast
exit
!
! *** L3 Protocols ***
!

! --- IP Directed Broadcast ---


! --- Proxy ARP ---


! --- UDP Broadcast Forwarding ---

ip forward-protocol udp 1900 "UPnP"

! --- VRRP ---


! --- Route Policies ---


! --- OSPF ---

router ospf
router-id 155.218.236.0
exit

! --- RIP ---

!
! *** DHCP SNOOPING ***
!
!
! *** ARP INSPECTION ***
!
!
! *** IP SOURCE GUARD ***
!
!
! *** IGMP ***
!
ip igmp op-mode non-5510
interface vlan 1
ip igmp snooping
ip igmp proxy
ip igmp send-query
exit
interface vlan 99
ip igmp snooping
exit
interface vlan 100
ip igmp snooping
ip igmp send-query
exit
interface vlan 101
ip igmp snooping
exit
no ip igmp ssm dynamic-learning
!
! *** STACK MONITOR ***
!
!
! *** SMLT ***
!
!
! *** SLPP ***
!
!
! *** SLPP-guard ***
!
!
! *** PIM ***
!
!
! *** UNICAST STORM CONTROL ***
!
!
! *** SLAMON ***
!
« Last Edit: March 19, 2015, 12:50:41 AM by cuber351 »


Offline cuber351

  • Rookie
  • **
  • Posts: 3
Re: Nortel 5510-48T Allowing UPnP Through VLAN's
« Reply #1 on: April 05, 2015, 11:10:14 PM »
100+ views and no replies? Is this just not possible on a 5510 without a subscription through avaya? I just want to have UPnP open some ports when needed.

Offline Telair

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 965
Re: Nortel 5510-48T Allowing UPnP Through VLAN's
« Reply #2 on: April 07, 2015, 05:04:57 PM »
Are both your router and end devices on the same VLAN, or are you trying to do multicast routing between VLAN's?  If they are on the same VLAN then I don't see why it won't work.

Offline cuber351

  • Rookie
  • **
  • Posts: 3
Re: Nortel 5510-48T Allowing UPnP Through VLAN's
« Reply #3 on: April 07, 2015, 11:13:00 PM »
End devices are on different VLANS than my switchport to router which are on their own VLAN.

Offline Telair

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 965
Re: Nortel 5510-48T Allowing UPnP Through VLAN's
« Reply #4 on: April 08, 2015, 05:54:07 PM »
OK, then your trying to do multicast routing which requires PIM-SM support if I remember correctly.  Been a long time since I played with multicast routing on a 5500 switch.  Anyway, PIM-SM is a licensed feature on 5500's.  So without a license I don't think you can get it working.

If anyone knows better than I do on this, I am totally willing to be corrected.   :)