• September 26, 2020, 05:34:24 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: Multicast App, Nortel 5520, Cisco 6509, Meraki MS42P  (Read 2615 times)

0 Members and 1 Guest are viewing this topic.

Offline brons2

  • Rookie
  • **
  • Posts: 17
Multicast App, Nortel 5520, Cisco 6509, Meraki MS42P
« on: February 14, 2014, 10:02:25 AM »
I've got a multi-vendor network here with a Cisco 6509 (12.2(33)SXI2a) at the core, a number of Nortel 5520s (FW:6.0.0.15  SW:v6.3.0.012), and some newer Meraki switches running whatever the latest software that Meraki pushes down from the cloud.

Ever since I got the Merakis, when I plug more than one of them into the network, Agent Desktop Display dies off.  When I go on the web interface for the Nortels, under the IGMP section and then Interface, it shows that the VLAN that is running IGMP has somehow "forgotten" the querier address.  If I pull the plug on the Merakis, after a few minutes, the Nortels "remember" the IGMP querier and everything goes back to normal.

All the switches are running IGMPv3, with snooping turned on for the desktop VLAN.  The 6509 is running PIM in sparse-dense mode, but we don't have a PIM license for the Nortels, so I can't enable PIM globally on the 5520s.  (Theoretically, I shouldn't need to enable PIM on the 5520 anyway because the switches are set up as straight layer 2 with about 5 VLANs on them).  I have tried to run the 6509 in Dense mode and in Sparse mode also to no effect.

Another oddity:  If I put 1 Meraki behind a Nortel 5520 rather than hanging it off the core, then, everything functions normally on the Nortels but clients on the Meraki cannot start Agent Desktop Display.  I have put a packet capture on this and there are some IGMP packets going between the Meraki and the client, but in this configuration the multicast destination is 224.0.0.22 whereas it should be 225.123.95.16 (and is when things are working properly). 

I tried designating the port from the Nortel to the Meraki as an mrouter port but that doesn't seem to make any difference.  Regardless, I don't want the Merakis behind the Nortels anyway, I want to plug the Merakis into the core without making the Nortels forget the IGMP querier.  The Merakis and the 6509 have 10Gb ports but the Nortels don't.

Well anyway.  Any assistance appreciated :)