• July 17, 2019, 03:18:50 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: MLT - not comming up  (Read 1116 times)

0 Members and 1 Guest are viewing this topic.

Offline AVAGO

  • Full Member
  • ***
  • Posts: 58
MLT - not comming up
« on: May 29, 2019, 07:08:14 AM »
Hi All
    could someone offer guidance as to why the MLT I have setup is failing.

So I have 3 stacks A,B,C 
Stack A has two 5520 and one 5510 ( stacked )  stack B & C have 1 5520 and 2 5510

I have created 2 MLT's on stack A ( MLT 1 is for Stack B and MLT 2 is for Stack C )

On Stack A MLT 1 has Ports 1/47,3/47, MLT 2 has ports 1/48,3/48

Stack B MLT 1 ports 1/47,3/47 and stack C MLT 1 is 1/48,3/48

So I have two connections from Stack A to Stack B and two connection from Stack A to Stack C.

below is the commands I have run on the switches
1)   5520-48T-PWR(config)#mlt 1 name "Stk-A-Stk-B"
2)     5520-48T-PWR(config)#mlt 1 member 1/47,3/47
3)     5520-48T-PWR(config)#mlt 1 learning disable
4)       5520-48T-PWR(config)#mlt 1 enable
5)     5520-48T-PWR(config)#spanning-tree mode RSTP
6)       5520-48T-PWR(config)#interface fastEthernet 1/1-46
7)     5520-48T-PWR(config-if)spanning-tree bpdu-filtering port 1/1-46 enable timeout 60
8     5520-48T-PWR(config)#vlan ports 1/47,3/47 tagging tagall
9)     5520-48T-PWR(config)#interface fastEthernet 1-46
10)   5520-48T-PWR(config-if)#spanning-tree rstp port 1-46 edge-port true#
11)   5520-48T-PWR(config)#interface fastEthernet 1/47-48,3/47-48
12)    spanning-tree rstp port 1/47-48,3/47-48 learning enable  ( read this as spanning tree on the port not the MLT )

The commands were repeated on the other stacks, The only other command that was run on the server stack was to make it the root Bridge spanning-tree rstp priority 0000, Have I set this too low ? should it be 1000 ?

When the stacks were restarted I couldn't connect to Stack B or C and stack A could not ping them from the CLI, I had to disable a port for each on the MLT's from Stack A ( so port 47 & 48 ) after these ports were disabled the stacks were accessible from the GUI and telnet.

Its a config setting either I have missed or that is incorrectly executed.

Stack A has 7 Vlans where as stack B & C only have 1 as they do not need the other VLANs

Looking at the sh running-config verbose module mlt, it is showing  the following
mlt 1 name "Stack-A-Stk-B" enable member 1/47,3/47
mlt 1 learning enable
mlt 1 bpdu all-ports
mlt 1 loadbalance basic
mlt 2 name "Stack-A-Stk-c" enable member 1/48,3/48
mlt 2 learning enable
mlt 2 bpdu all-ports
mlt 2 loadbalance basic
! *** MLT (Phase 2) ***
!
no mlt shutdown-ports-on-disable
mlt 1 learning enable
mlt 2 learning enable

But I set the MLT to learning disable - Should it be disable as the ports have spanning tree enabled (12) , Could this be the cause ?

Any advise gratefully received

« Last Edit: May 29, 2019, 07:47:37 AM by AVAGO »