• April 23, 2019, 06:51:32 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: ERS5650TD-PWR fans surging  (Read 1027 times)

0 Members and 1 Guest are viewing this topic.

Offline kthelen

  • Rookie
  • **
  • Posts: 8
ERS5650TD-PWR fans surging
« on: February 13, 2019, 05:26:43 PM »
Just picked up a couple of used 5650TD-PWR units. Both of them seem to vary the speed of the fans, raising the RPMs for maybe 0.5 second every 2 seconds. Is this normal? Can they be configured to run at a steady speed?


Offline TankII

  • Hero Member
  • *****
  • Posts: 553
Re: ERS5650TD-PWR fans surging
« Reply #1 on: February 14, 2019, 02:26:49 PM »
Anything via Console?

Did you blow the fans and chassis out?

Is it the chassis or power supply fans that are noisy?

I would try cleaning the units of all dust, just in case the internal thermistors are being set off due to hot spots.

What code version are they on?

Offline kthelen

  • Rookie
  • **
  • Posts: 8
Re: ERS5650TD-PWR fans surging
« Reply #2 on: February 14, 2019, 03:01:33 PM »
>Anything via Console?

All the fans are listed as OK. Not sure what other things I might check... suggestions?


> Did you blow the fans and chassis out?

Yes.


> Is it the chassis or power supply fans that are noisy?

Chassis.


> I would try cleaning the units of all dust, just in case the internal thermistors are being set off due to hot spots.

Will give them a more thorough cleaning and see if that makes any difference.


> What code version are they on?

They were all on various versions when I got them (total of four, all from the same eBay seller - had only received the first two yesterday) and all behave exactly the same way. I cleared all their configs, and installed diagnostic 6.0.0.21 and agent 6.3.6.017s; no change.

I've never had any 5650s before, so I don't know what's normal or not. I do have a lot of 5520s, and a few 5698s, all of which run this same software, and all of which just hum along at a steady RPM when running.

Offline TankII

  • Hero Member
  • *****
  • Posts: 553
Re: ERS5650TD-PWR fans surging
« Reply #3 on: February 14, 2019, 05:22:35 PM »
I have experienced this with the power supply fans, not chassis fans.  6.3.6 is solid, though the recommended code is 6.6.3 for 5600's.  You get lots of additional features like fabric attach proxy (which supports Extreme AP Zero-touch-provisioning), VRF-lite, and others.
When I was participating in the 5600 BETA, i asked a MIB for inlet temperature be added like the 8600 has.  Unfortunately, it is part of the mainboard and they could not do so.  It would have been useful to try and solve issues like this!



Offline kthelen

  • Rookie
  • **
  • Posts: 8
Re: ERS5650TD-PWR fans surging
« Reply #4 on: February 14, 2019, 05:33:41 PM »
Decided to run one with the top off, just to see if I could isolate the issue better. Turns out it's only the center chassis fan that's doing the revving.

When power is applied, all the fans do the hi-lo speed test. Then the outer two idle, and the center one raises and lowers its speed endlessly as described. This begins within seconds of power-on, before the agent is even loading.

Offline kthelen

  • Rookie
  • **
  • Posts: 8
Re: ERS5650TD-PWR fans surging
« Reply #5 on: February 26, 2019, 10:17:51 AM »
Bump.

There's got to be something I'm missing here. Any thoughts?

Offline TankII

  • Hero Member
  • *****
  • Posts: 553
Re: ERS5650TD-PWR fans surging
« Reply #6 on: February 26, 2019, 03:10:35 PM »
It sounds like the third wire which measures the fan speed is broken or the sensor in the fan is bad. 

Offline kthelen

  • Rookie
  • **
  • Posts: 8
Re: ERS5650TD-PWR fans surging
« Reply #7 on: February 26, 2019, 03:31:14 PM »
It sounds like the third wire which measures the fan speed is broken or the sensor in the fan is bad.

I actually tried (for lack of ideas) swapping fans around, and even disconnecting the third wire. No change. I kinda want to put a meter on that particular fan output to see if it's running the voltage up/down, turning the voltage on/off, or what's going on.

Offline kthelen

  • Rookie
  • **
  • Posts: 8
Re: ERS5650TD-PWR fans surging
« Reply #8 on: February 27, 2019, 11:15:11 AM »
Just checked it out with a voltmeter. Of the three fans, only the middle one experiences this issue - and it's the same on on all four switches. That middle output sits at 11V with no fan connected, and jumps continuously between 6V and 11V with a fan connected. (The other outputs start out at 11V, then drop to a lower continuous voltage after the switch has been powered on for several seconds.)

I can rearrange the fans any way I wish, and the problem appears on whatever fan is connected to that middle connector.

It's really odd that four switches in a row would have this very same issue. Would seem almost impossible for all four to have experienced a hardware failure so specific - but yet the diagnostic, agent, and config have all been replaced, so I'm not sure what it would be software-wise. I'm stumped.