• October 31, 2020, 04:05:09 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: ERS5632 trunk uplink not working with Cisco switch  (Read 3838 times)

0 Members and 1 Guest are viewing this topic.

Offline sam4u

  • Rookie
  • **
  • Posts: 8
ERS5632 trunk uplink not working with Cisco switch
« on: September 11, 2015, 05:52:45 AM »
Hello,

We have Avaya ERS5632 (Stack 2Pair) switches.

First switch vlan 451 port 1/31(trunk) tagging enable is connected on Cisco L3 switch( secondary Uplink)
Secondary switch vlan 451 port 2/31(trunk) tagging enable is connected on Juniper L3 switch(Primary Uplink)

VRRP is running between Cisco L3 switch and Juniper L3 switch.

when both the Avaya switch port 1/31,2/31 is up, VRRP status of Cisco L3 switch shows backup and Juniper L3 switch status show Master.

when i shut the primary uplink of Avaya switch port 2/31 of Juniper L3 switch, Cisco L3 switch VRRP status becomes Master but traffic doesn't flow, All the  host connected on Vlan 451 is not reachable via Cisco L3 switch trunk uplink.

Please suggest
« Last Edit: September 11, 2015, 11:31:25 PM by sam4u »


Offline Telair

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 965
Re: ERS5632 trunk uplink not working with Cisco switch
« Reply #1 on: September 11, 2015, 12:51:36 PM »
First, what version of code are you running on your 5632's? 

Second, that doesn't sound like a switch issue to me.  In most VRRP implementations each router has two IP addresses.  The virtual IP address they share as well as their own IP.  I would expect you are able to ping the Cisco's actual IP address no matter what (but Cisco is not my specialty). 

Offline sam4u

  • Rookie
  • **
  • Posts: 8
Re: ERS5632 trunk uplink not working with Cisco switch
« Reply #2 on: September 11, 2015, 01:36:21 PM »
Base Unit Selection:   Base unit using rear-panel switch
sysDescr:              Ethernet Routing Switch 5632FD
                       HW:08       FW:6.0.0.15  SW:v6.6.1.033
                       Mfg Date:05242013    HW Dev:none
Serial #:              LBNNTMJPW506VR
Operational Software:  FW:6.0.0.15   SW:v6.6.1.033
Installed software:    FW:6.0.0.15   SW:v6.6.1.033
Operational license:   Advanced software
Installed license:     Advanced software
sysObjectID:           1.3.6.1.4.1.45.3.74.5
sysUpTime:             0 days, 10:03:14
sysNtpTime:            NTP not synchronized.
sysRtcTime:            Friday 2015/09/11 13:29:40
sysServices:           6

Port connected to Cisco L3 switch
sw#sh int 1/31 conf
Unit/Port:  1/31
    Trunk:
    Admin Status:  Enable
    Oper Status:  Up
    EAP Oper Status:  Up
    VLACP Oper Status:  Down
    STP Oper Status:  Discarding
    Link: Up
    Last Change: 0 day(s), 10h:05m:41s ago
    LinkTrap:  Enabled
    Link Autonegotiation:  Disabled
    Link Speed:  10Gbps
    Link Duplex:  Full-Duplex
    Flow Control:  Disable
    Wan Mode:  LAN
    Energy Saver: Disabled
    Energy Saver Oper Status: No Power Saving
    BPDU-guard (BPDU Filtering): Disabled
    BPDU-guard (BPDU Filtering) Oper Status: N/A
    SLPP-guard: Disabled
    SLPP-guard Oper Status: N/A
    SLPP: Disabled
    SLPP Oper Status: N/A

*****VLAN interfaces configuration*****
           Filter     Filter
          Untagged Unregistered
Unit/Port  Frames     Frames    PVID PRI    Tagging    Name
--------- -------- ------------ ---- --- ------------- ----------------
1/31      No       Yes          451  0   TagAll        Unit 1,Port 31

*****VLAN ID port member configuration*****
Unit/Port VLAN VLAN Name         VLAN VLAN Name         VLAN VLAN Name
--------- ---- ----------------  ---- ----------------  ---- ----------------
1/31      451  Pub
--------- ---- ----------------  ---- ----------------  ---- ----------------

*****Spanning-tree port configurations*****
Unit/Port     Role       State     STP Status  Oper Status
---------  ----------  ----------  ----------  -----------
1/31       Disabled    Discarding  Disabled    Enabled
sw#

Offline sam4u

  • Rookie
  • **
  • Posts: 8
Re: ERS5632 trunk uplink not working with Cisco switch
« Reply #3 on: September 11, 2015, 01:41:12 PM »
Im not able to ping the Cisco router ip or Virtual ip :(

Offline Telair

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 965
Re: ERS5632 trunk uplink not working with Cisco switch
« Reply #4 on: September 11, 2015, 05:07:01 PM »
So when both ports to the Juniper and Cisco are working, can you ping the Cisco's IP address then?  Also, is your PVID on that port 451?  Isn't it supposed to be 300?

Offline sam4u

  • Rookie
  • **
  • Posts: 8
Re: ERS5632 trunk uplink not working with Cisco switch
« Reply #5 on: September 11, 2015, 11:29:52 PM »
i created new vlan 451 and now both the trunk ports 1/31 & 2/31 are in vlan 451 and pvid is also 451.

Yes when both the ports are up im able to ping the gateway(VRRP) ip,  from juniper L3 switch im able to reach, also router is able to learn all the arp/mac of hosts connected on vlan 451,

Offline Telair

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 965
Re: ERS5632 trunk uplink not working with Cisco switch
« Reply #6 on: September 14, 2015, 03:36:00 PM »
Maybe take a look in the MAC tables on the switches.  See where the MAC addresses for the Cisco and the Juniper are pointing and what happens to them when they change.  Also, is the new gateway sending out a gratuitous ARP so everything on the subnet knows it is the new gateway?  If not, then the devices on the subnet may be sending to the old gateway's MAC address still as they don't realize it has changed.

Offline sam4u

  • Rookie
  • **
  • Posts: 8
Re: ERS5632 trunk uplink not working with Cisco switch
« Reply #7 on: September 14, 2015, 04:25:13 PM »
ok will check that.

f.y.i
today i  swapped the cables of both the trunk ports with each other to check the whether any port issue.
but found that after swapping also only Juniper trunk is working and Cisco is not working which means Avaya switch ports are working fine...correct?