• September 19, 2020, 06:43:31 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: ERS 5600 - ECMP OSPF issue  (Read 2521 times)

0 Members and 1 Guest are viewing this topic.

Offline nashim

  • Rookie
  • **
  • Posts: 9
ERS 5600 - ECMP OSPF issue
« on: January 14, 2014, 03:35:41 PM »
Hi Team,

One of the customer has configured OSPF ECMP and his query is why the two routers are not getting equal traffic from ERS5600.V6.2.4

- from port 1/1 one Router R1 is connected.
- from port 1/2 another Router R2 is connected.
when customer is monitoring in a tool, he is getting uneven traffic in both the routers, say in R1 traffic is 100kbps, whereas in R2 traffic is 200kbps.

Note :- R1 & R2 are cisco device.

Configuration in ERS5600:-

--- ECMP ---



ospf maximum-path 2



ip route 0.0.0.0 0.0.0.0 172.16.10.249 1

ip route 143.61.17.0 255.255.255.0 172.16.10.249 1

ip route 143.61.42.0 255.255.255.0 172.16.10.2 1

ip route 209.82.193.0 255.255.255.0 172.16.10.1 1

ip route 209.82.216.0 255.255.255.0 172.16.10.249 1

Please help me in this regard


Offline Telair

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 965
Re: ERS 5600 - ECMP OSPF issue
« Reply #1 on: January 14, 2014, 05:45:47 PM »
ECMP does not load balance on a per-packet basis, but on the IP source and destination of the packet.  If system "A" is sending to "B" and "C", "A" will always send to "B" over the same ECMP link as long as it is available for use.  If "A" sends to "C" though, it may take a different link depending on how the hash operation comes out.  So if "A" send 200kbps to "B" and "A" sends 100kbps to "C", it is very possible that one link shows as moving 200kbps and the other shows 100kbps and ECMP is working as it should.

This document on page 251 and later can explain ECMP to you in more detail.
http://downloads.avaya.com/css/P8/documents/100115400

Offline Michael McNamara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • michaelfmcnamara
    • Michael McNamara
Re: ERS 5600 - ECMP OSPF issue
« Reply #2 on: January 16, 2014, 08:41:47 PM »
Brilliant!!!
We've been helping network engineers, system administrators and technology professionals since June 2009.
If you've found this site useful or helpful, please help me spread the word. Link to us in your blog or homepage - Thanks!

Offline nashim

  • Rookie
  • **
  • Posts: 9
Re: ERS 5600 - ECMP OSPF issue
« Reply #3 on: January 17, 2014, 09:20:47 AM »
Thank you  :)