• September 23, 2020, 08:50:20 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: configuration for avaya ers 3650t pwr+  (Read 5207 times)

0 Members and 1 Guest are viewing this topic.

Offline sepe

  • Rookie
  • **
  • Posts: 11
configuration for avaya ers 3650t pwr+
« on: June 03, 2013, 05:38:43 AM »
hi,
we have a scenario where we have got Avaya ers 3650pwr+ (poe) and we are planning to implement ip telephony solution where we have Avaya media gateway, Avaya AES and Avaya application server....with Avaya 9608ip phones...
now I want all my servers and ip phones to be plugged on to this (POE) switch..
so I am planning to make 2 vlans..one for data and one for voice..
data vlan would be 100 192.168.1.0/24  ( office computers, application server...)
voice vlan would be 200. 192.168.2.0/24 ( Ip phones, avaya media gateway ,Avaya vp)
and I want to make 1 port as TRUNK to connect it to router at backbone.

can any one help me with the switch configuration how shall I proceed ...

Thanks in advance...


Offline Johan Witters

  • Sr. Member
  • ****
  • Posts: 252
    • BKM Networks
Re: configuration for avaya ers 3650t pwr+
« Reply #1 on: June 03, 2013, 07:08:56 AM »
Hi Sepe,

I pasted the configuration I normally use... you still need to do some changes (ip addresses etc) I also configure the "dual identity" port 21-24 as uplinks, change these to if you need more access ports



enable
configure terminal
!
! *** CORE ***
!
sntp server primary address x.x.x.x
sntp enable
cli password serial local
cli password telnet local
username "RO" "password" ro
username "RW" "passwordrw" rw
!
! *** SNMP ***
!
snmp-server contact "helpdesk"
snmp-server name "switchname"
snmp-server location "location"
snmp-server community "rw_community" rw
!
! *** IP  ***
!
ip default-gateway x.x.x.x
ip address switch x.x.x.x 255.255.255.0
ip address source configured-address
!
! *** RSTP (Phase 1) ***
!
!The Spanning tree operation mode cannot be changed without rebooting.
!The Spanning tree operation mode is required to be set to RSTP before
!loading this ASCII configuration file.
spanning-tree mode rstp
!
! *** VLAN ***
!
vlan create 10 type port
vlan name 1 "Data"
vlan name 10 "Voice"
vlan ports 3-20 tagging unTagPvidOnly
vlan ports 22-26 tagging tagAll filter-untagged-frame enable
vlan configcontrol flexible
vlan members 1 3-26
vlan members 10 1-26
vlan ports 1-2 pvid 10
no auto-pvid
!
!
! *** QOS ***
!
qos if-group name "Voice_Priority" class unrestricted
qos l2-element 1 name "Voice_ClfrE" vlan-min 10 vlan-max 10 ethertype 0x800
qos classifier 1 set-id 1 name "Voice_Clfr" element-type l2 element-id 1
qos if-assign port 1-24 name Voice_Priority
qos policy 1 name "Voice_Priority" if-group "Voice_Priority" clfr-type classifier clfr-id 1 in-profile-action 6 precedence 2 track-statistics individual
!
!
! *** Interface ***
!
interface FastEthernet ALL
name port 1 "Avaya VP"
name port 2 "Avaya Media gateway"
name port 24 "Uplink"
exit
!
! *** Rate-Limit ***
!
rate-limit both 10
!
!
! *** RSTP (Phase 2) ***
!
interface FastEthernet ALL
spanning-tree rstp port 1-20 edge-port true
spanning-tree bpdu-filtering port 3-20 enable
exit
!
!
! *** RTC ***
!
clock time-zone West 1 0
!
! *** Routing ***
!
ip routing
interface vlan 10
ip address 192.168.2.x 255.255.255.0
ip routing
Kind regards,

Johan Witters

Network Engineer
BKM NV

Offline sepe

  • Rookie
  • **
  • Posts: 11
Re: configuration for avaya ers 3650t pwr+
« Reply #2 on: June 04, 2013, 04:02:39 AM »
hi johan,

thanks for the quick reply..

i just wanted to confirm if i realy need spanning tree to be configured in my switch..as i am using only one switch and chances for the LOOP is negligible...
and can you refer me some document where i can refer for more information..
and according to my understanding does this command
 "vlan ports 22-26 tagging tagAll filter-untagged-frame enable" will make my port TRUNk...as i am going to connect this switch with cisco router at backbone...
and on these configuration
vlan members 1 3-26   
vlan members 10 1-26
vlan ports 1-2 pvid 10  (what this command will going to do)?????? as i have seen these two ports will be conncted to voice portal and other server.)
no auto-pvid


kindly help

thanks

Offline Johan Witters

  • Sr. Member
  • ****
  • Posts: 252
    • BKM Networks
Re: configuration for avaya ers 3650t pwr+
« Reply #3 on: June 04, 2013, 05:51:44 PM »
I would configure spanning tree even in this scenario. You never know of your network will grow, and patching mistakes are as easy to make on a 1 switch network..

the command "vlan ports 22-26 tagging tagAll filter-untagged-frame enable" will indeed turn ports 22 till 26 into a trunk, and dropping all untagged packets coming into the interface. In case you want to plug in a Cisco switch, you better use "vlan ports 22-26 tagging untagpvidonly filter-untagged-frame disable". In this case the switch will only tag vlan 10, and will allow untagged packets ingres, and send vlan 1 packets untagged towards the Cisco.

"vlan members 1 3-26" indicates ports 3 till 26 are member of vlan 1 (1 and 2 are for gateway and vp in voice vlan)
"vlan members 10 1-26" indicateds all ports are in the voice vlan

"vlan ports 1-2 pvid 10" sets the pvid (defaultvlanid) (equals Native vlan in Cisco) to 10. This is important if the port tagging mode is untagall, tagpvidonly or untagpvidonly. In this case ports 1 and 2 are untagall, so the switch needs to know that all ingress (untagged) packets have to be put in vlan 10

Some more info can be found in http://downloads.avaya.com/css/P8/documents/100134063, it's for the 4000-series switches, but it makes little or no difference..
Kind regards,

Johan Witters

Network Engineer
BKM NV

Offline sepe

  • Rookie
  • **
  • Posts: 11
Re: configuration for avaya ers 3650t pwr+
« Reply #4 on: June 05, 2013, 04:11:34 AM »
hi,

thanks for your easy explanation..

now I just wanted to confirm after doing all these configuration over the switch. when I plug my cisco router on one of the port out of 22-26.with  "vlan ports 22-26 tagging untagpvidonly filter-untagged-frame disable...
and doing these below configuration will everything works like vlan routing and everything...
as there would be 2 network ....
vlan 10(voice)---10.0.0.128/25
vlan 20 (data)--10.0.0.1/25

router configurations would be

Router(config-subif)#int fa0/0.1
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip add 10.0.0.128  255.255.255.128
Router(config-subif)#int fa0/0.2
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip add 10.0.0.1  255.255.255.128

and one more thing as u have said I should configure

ip default-gateway x.x.x.x
ip address switch x.x.x.x 255.255.255.0
ip address source configured-address

in this what would be my default gateway....as default gateway would be off router....
but in router I am only making two subinterfaces..for vlan 10 and vlan 20...which are 10.0.0.1 and 10.0.0.128 netowrks...
then what should I enter in default gateway,,,???

Offline Johan Witters

  • Sr. Member
  • ****
  • Posts: 252
    • BKM Networks
Re: configuration for avaya ers 3650t pwr+
« Reply #5 on: June 05, 2013, 04:34:57 AM »
hello Sepe,

as your data vlan is 20 instead of 1, this changes the game plan a little bit... You need to add vlan 20 for your data vlan, change the ports from 1 to 20 on the switch. Also, you have to change the mode for your router port back to tagall because the default native vlan on the Cisco router will be 1, even if it is not assigned to the vlan interface.. Making vlan 20 management vlan on the switch will allow the switch to react to traffic for it's address in the data vlan.
You should add following commands (after the commands earlier in the thread")

vlan create 20 type port
vlan name 1 "Unused"
vlan name 20 "Data"

vlan mem remove 1 all
vlan mem 20 3-26
vlan ports 3-26 pvid 20
vlan ports 22-26 tagging tagall

vlan mgmt 20

ip default-gateway 10.0.0.1

! because intervlan routing is performed on the Cisco, you can disable routing on the switch, and remove the ip address in the voice vlan if you like:

interface vlan 10
no ip routing
no ip address
exit

no ip routing
Kind regards,

Johan Witters

Network Engineer
BKM NV

Offline sepe

  • Rookie
  • **
  • Posts: 11
Re: configuration for avaya ers 3650t pwr+
« Reply #6 on: June 05, 2013, 06:22:24 AM »
hi johan,
As per your guidance the end to end configuration would be like this.....
Requirement
2 vlans
one data           VLAN 20----------10.0.0.1/25
second voice     VLAN 10----------10.0.0.128/25
SWITCH******

! *** IP  ***
ip default-gateway 10.0.0.1
ip address switch 10.0.0.2 255.255.255.0
ip address source configured-address

********************************************
 *** VLAN ***
!
vlan create 10 type port
Vlan create 20 type port
vlan name 1 "unused"
vlan name 10 "Voice"
vlan name 20 "data"
vlan ports 3-20 tagging unTagPvidOnly
vlan ports 22-26 tagging tagAll filter-untagged-frame enable   (OR)   vlan ports 22-26 tagging tagall
vlan configcontrol flexible
vlan mem remove 1 all
vlan members 20 3-26
vlan ports 3-26 pvid 20.....(THIS IS CORRECT)..???
vlan members 10 1-26
vlan ports 1-2 pvid 10....(THIS IS CORRECT)..???
no auto-pvid

vlan mgmt 20

*********************************************

************ROUTER

Router(config-subif)#int fa0/0.1
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip add 10.0.0.128  255.255.255.128
Router(config-subif)#int fa0/0.2
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip add 10.0.0.1  255.255.255.128...


***********************************************
and what about the discovery protocols like ADAC or LLDP...u no where mentioned that.....wont I have to enable that also?????

and is it possible/safe to do these basic configurations from EDM..??

thanksss

Offline Johan Witters

  • Sr. Member
  • ****
  • Posts: 252
    • BKM Networks
Re: configuration for avaya ers 3650t pwr+
« Reply #7 on: June 05, 2013, 07:15:30 AM »
The configuration is correct...

pvid 10 and pvid 20 on the ports are to indicate the native/untagged vlan. This should be 20 for all ports on which pc's are to be connected, 10 on the ports where the voice gateway etc are connected.

You should be able to use ADAC or LLDP-MED for Avaya phones, but we install Aastra phones and configure them through DHCP.
Kind regards,

Johan Witters

Network Engineer
BKM NV

Offline sepe

  • Rookie
  • **
  • Posts: 11
Re: configuration for avaya ers 3650t pwr+
« Reply #8 on: June 05, 2013, 07:18:49 AM »
hi,
thanks johan for your kind & quick support and making clear all my queries...