• November 26, 2020, 06:40:54 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: Basic OSPF config on ERS?  (Read 9317 times)

0 Members and 1 Guest are viewing this topic.

Offline Gipper

  • Jr. Member
  • **
  • Posts: 34
Basic OSPF config on ERS?
« on: July 02, 2013, 04:05:04 PM »
Hi All, I've read through a lot of posts and docs, but didn't see anything that discussed a "basic" OSPF config on an ERS.  What would be helpful is seeing the equivalent Cisco OSPF commands on an ERS.  We have many remote offices that connect to an MPLS provider and we use OSPF to handle routing between these offices.  The MPLS providers internal routers also talk OSPF.  All of our sites are assigned a different "Area" and the backbone is Area 0.  Most sites have a handful of VLAN's that are all directly connected to the local L3 Switch and we always use VLAN 20 as our egress to the MPLS managed router.  Here's a typical OSPF config from one of our remote sites that uses Cisco gear.  Now I need to bring a new office with all Avaya gear into the MPLS mix. What would be the comparable OSPF config for an ERS?  *I do have an Advanced License on our ERS 4850 Stack (v5.6.3.) and everything is running and working well internally.   

Basic Cisco L3 switch OSPF config of remote site -
 
interface Vlan10
 ip address 10.10.10.1 255.255.255.0
interface Vlan11
 ip address 10.10.11.1 255.255.255.0
interface Vlan12
 ip address 10.10.12.1 255.255.255.0
interface Vlan20
 ip address 10.20.1.1 255.255.255.252

router ospf 1
 network 10.20.1.0 0.0.0.3 area 0
 network 10.10.10.0 0.0.0.255 area 1
 network 10.10.11.0 0.0.0.255 area 1
 network 10.10.12.0 0.0.0.255 area 1
 

Thanks!
« Last Edit: July 02, 2013, 04:15:12 PM by Gipper »


Offline Paul L

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 755
    • paulaleroux
    • Paul's Networking blog
Re: Basic OSPF config on ERS?
« Reply #1 on: July 02, 2013, 07:50:38 PM »
on the stackables the cli syntax is somewhat similar to Cisco.  As you navigate through the CLI commands the "?" will be your friend.

the commands you have shown above will be very similar to the commands you will need to put on your 4500.

I would start here  http://downloads.avaya.com/css/P8/documents/100123820    doesn't get more basic than that.
ACSS- Avaya Enterprise Routing Switch  #8

Offline telecom116

  • Sr. Member
  • ****
  • Posts: 217
Re: Basic OSPF config on ERS?
« Reply #2 on: July 03, 2013, 11:05:32 AM »
I have quite a few ERS switches terminating MetroE connections.  Here are some of basic ERS 55xx (and 4xxx) OSPF programming tips:

- You will need to have an Advanced Routing license on the switch;
- Routing and OSPF enabling settings have to be turned on at multiple places.  Personal knowledge has caused me to bang my head on the wall, even after many years of experience, trying to remember the commands to enable OSPF routing in all the required places in the NNCLI/ACLI.

Here's some config to get you started:
ip routing # this is the global command to turn on routing
interface vlan 1
no ip routing # turn off routing on VLAN 1 because you probably don't have any interfaces on it
exit
interface vlan 10
ip address 10.10.10.1 255.255.255.0
exit
interface vlan 11
ip address 10.10.11.1 255.255.255.0
exit
interface vlan 12
ip address 10.10.10.1 255.255.255.0
exit
interface vlan 20
ip address 10.20.1.1 255.255.255.252
exit

router ospf enable  #enable OSPF routing globally
router ospf  #gate opener for OSPF configuration
router-id 10.20.1.1
as-boundary-router enable # since you have multiple OSPF areas and this switch will have to be a ASBR
no rfc1583-compatibility enable  # match to the rest of your network; ERS defaults to rfc1538 enabled
area 1  #default OSPF area for the switch

interface vlan 10
ip ospf enable
exit
interface vlan 11
ip ospf enable
exit
interface vlan 12
ip ospf enable
exit
interface vlan 20
ip ospf area 0
ip ospf enable
exit

« Last Edit: July 03, 2013, 11:07:45 AM by telecom116 »

Offline Gipper

  • Jr. Member
  • **
  • Posts: 34
Re: Basic OSPF config on ERS?
« Reply #3 on: July 05, 2013, 09:35:45 AM »
thanks guys, especially telecom116 for the sample.  That should be enough to push me in the right direction.  Our mpls circuit is due in by 7/15 (right now I'm using site-to-site VPN to connect to the mothership). I'll let post my OSPF config once I get it working to hopefully help others down the road.

Offline Gipper

  • Jr. Member
  • **
  • Posts: 34
Re: Basic OSPF config on ERS?
« Reply #4 on: July 15, 2013, 10:40:23 PM »
Well, so far no luck... I wanted to test with the only the vlan attached to area 0 (vlan 20) and my server vlan = vlan 50.

I implemented the following (*IP Routing, VLAN's and IP addressing were previously configured and are currently working fine using site-to-site VPN tunnels).

conf t
router ospf enable
router ospf
router-id 10.20.8.1
as-boundary-router enable
no rfc1583-compatibility enable
area 0.0.0.8
exit

interface vlan 50
ip ospf enable
exit

interface vlan 20
ip ospf area 0.0.0.0
ip ospf enable
exit

--------------------
I tried enabling and disabling RFC1585 compatibility.  No matter what I do, I'm showing OSPF neighbors = 0 from "show IP OSPF Neighbor".  Any idea where I'm going wrong?

« Last Edit: July 17, 2013, 12:05:22 AM by Gipper »

Offline Gipper

  • Jr. Member
  • **
  • Posts: 34
Re: Basic OSPF config on ERS?
« Reply #5 on: July 17, 2013, 12:02:56 AM »
OK, finally got it working.  The config above was fine, but what ended up gettting OSPF talking between Avaya and our provider was setting the area 0 interface to broadcast.  >

interface vlan 20
ip ospf area 0.0.0.0 network broadcast
ip ospf enable
exit

Offline Michael McNamara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • michaelfmcnamara
    • Michael McNamara
Re: Basic OSPF config on ERS?
« Reply #6 on: July 17, 2013, 09:25:32 AM »
What version of code?

I believe the default setting is 'broadcast'.
We've been helping network engineers, system administrators and technology professionals since June 2009.
If you've found this site useful or helpful, please help me spread the word. Link to us in your blog or homepage - Thanks!

Offline Gipper

  • Jr. Member
  • **
  • Posts: 34
Re: Basic OSPF config on ERS?
« Reply #7 on: July 17, 2013, 10:23:09 AM »
What version of code?

I believe the default setting is 'broadcast'.

v5.6.3  The only reason I even tried that setting was based on an old thread here where KT said he could only get OSPF talking to his Service Provider by setting the interface to braodcast.  >>  https://forums.networkinfrastructure.info/nortel-ethernet-switching/ospf-configure-for-ers-5520/

And FTR, I concur with KT, Love this forum!   8)