• February 21, 2018, 11:43:40 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: Assertation failed on 5530  (Read 1557 times)

0 Members and 1 Guest are viewing this topic.

Offline JaySmith

  • Jr. Member
  • **
  • Posts: 34
Assertation failed on 5530
« on: December 14, 2015, 09:13:33 PM »
I booted and no lights when plugged in. I connected serial cable, and it crashes with this error:

Quote
Initializing ......
ERROR: Assertion failed: (sem) at sync.c:117
ERROR: Stack trace follows
FUNC = 0x20760, PC = 0x207ac (0x207ac), SP = 0x7fffc10
FUNC = 0x207e4, PC = 0x20800 (0x20800), SP = 0x7fffc20
FUNC = 0x2095c, PC = 0x209bc (0x209bc), SP = 0x7fffc30
FUNC = 0x5ef14, PC = 0x5efd8 (0x5efd8), SP = 0x7fffc40
FUNC = 0x227bac, PC = 0x227f94 (0x227f94), SP = 0x7fffc90
FUNC = 0x228070, PC = 0x228118 (0x228118), SP = 0x7fffcc0
FUNC = 0x21c634, PC = 0x21c6d4 (0x21c6d4), SP = 0x7fffce0
FUNC = 0x8865c8, PC = 0x886608 (0x886608), SP = 0x7fffd00
FUNC = 0x1154c, PC = 0x1173c (0x1173c), SP = 0x7fffd60
FUNC = 0x9b5890, PC = 0x9b58f8 (0x9b58f8), SP = 0x7fffd90
RA 0x0 out of range

I connect via console and hit escape to enter diagnostic mode. I hit e to display errors, and get this:

Quote
Press 'a'  to run Agent code
Press 'd'  to Download agent code
Press 'e'  to display Errors
Press 'i'  to Initialize config/log config control in Both flash
Press 'p'  to run POST tests..

System Resets  =       37.

Burn-In Loops  =        0.
Burn-In Errors =        0.
Auto-Burn-In   = DISABLED
Diag Baud      =     9600.

Error Log:
Bad Port Mask  = 00000000=LS; MS=00000000

[size=78%]Loop Test Error Description:[/size][/color](none)

I hit I to initialize config/log and then get this:

Quote
Press 'a'  to run Agent code
Press 'd'  to Download agent code
Press 'e'  to display Errors
Press 'i'  to Initialize config/log config control in Both flash
Press 'p'  to run POST tests..

Program  (0x0700)
  PC/SRR0= 00000000  MSR/SRR1= 00082032  SP/R1=00BC19BC
  LR=  00010C2C CR = 80000400  CTR= 00000000  XER= 20000000
  R0 = 00000004 R1 = 00BC19BC  R2 = 00000000  R3 = 00000000
  R4 = 80000000 R5 = 00016F90  R6 = 00000001  R7 = 00000004
  R8 = 00000019 R9 = 002E368E  R10= 002E368E  R11= 00010C24
  R12= 00120010 R13= 80504500  R14= 00000000  R15= 08000000
  R16= 07ED6B40 R17= 17D78400  R18= 70000000  R19= 70000000
  R20= 70000000 R21= 002C459A  R22= 00000000  R23= 00000004
  R24= 00000010 R25= 0000002A  R26= 00000001  R27= 002C448C
  R28= 00000045 R29= 0014FD7C  R30= 000001D0  R31= 00000000
  @ESF=002C20D8

I can't connect to tftp server because no ports work. I was hoping to try and reflash uploading over serial, but not sure how.

Any help would be appreciated.


Offline Dominik

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1564
    • Networkautobahn
Re: Assertation failed on 5530
« Reply #1 on: December 15, 2015, 05:20:46 AM »
You can try option "a" in the diag.

There you can assign a temp IP and Port for uploading an SW Image.
The upload the SW Image via Serial is not supported.

The ERS5530 still has a lifetime warrenty. For the case the SW upload fails I would suggest to replace the HW.

Cheers
Itīs always the networks fault!
networkautobahn.com

Offline JaySmith

  • Jr. Member
  • **
  • Posts: 34
Re: Assertation failed on 5530
« Reply #2 on: December 15, 2015, 05:35:40 AM »
Option A in diag just boots the firmware image,  at which point it locks up. What are the conditions for Avaya to honor the lifetime warranty? I was looking around but was not able to find any info.

Offline JaySmith

  • Jr. Member
  • **
  • Posts: 34
Re: Assertation failed on 5530
« Reply #3 on: December 15, 2015, 07:14:35 AM »
I should mention I do not have a service contract with avaya.

Offline JaySmith

  • Jr. Member
  • **
  • Posts: 34
Re: Assertation failed on 5530
« Reply #4 on: December 15, 2015, 09:51:18 AM »
Just got off the phone with Avaya, they are shipping me a new one. Thank you much for your help.

Offline Dominik

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1564
    • Networkautobahn
Re: Assertation failed on 5530
« Reply #5 on: December 15, 2015, 11:56:59 AM »
Thanks for the feedback.

Good to hear that you get a replacemnt unit from Avaya.

Cheers
Itīs always the networks fault!
networkautobahn.com