• September 19, 2020, 02:18:10 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: ADAC configuration on 5520  (Read 5288 times)

0 Members and 1 Guest are viewing this topic.

Offline TonsOfSteel

  • Jr. Member
  • **
  • Posts: 38
ADAC configuration on 5520
« on: October 09, 2013, 11:33:21 AM »
I am configuring ADAC on a 5520 test switch with SW:v6.2.5.027 using Aastra IP Phones. I have followed Michael's post, which is awesome btw, to configure the switch.
http://blog.michaelfmcnamara.com/2007/10/nortel-ers-5520-pwr-switch/#comment-18824

The Phone is getting a DHCP address off of my Data Vlan instead of the Voice Vlan. Is there any way to configure this to have the phone get an address off of the Voice Vlan?
Some show commands:

5520-VoIP-Test(config)#show adac
       ADAC Global Configuration
---------------------------------------
ADAC Admin State:  Enabled
ADAC Oper State:  Enabled
Operating Mode:  Tagged Frames
Voice-VLAN ID:  112
Call Server Port:  None
Uplink Port:  1,48


5520-VoIP-Test(config)#show adac interface 1/5
            Auto       Oper      Auto
Port  Type  Detection  State     Configuration  T-F PVID   T-F Tagging
----  ----  ---------  --------  -------------  ---------  ---------------
5     T     Enabled    Enabled   Applied        No Change  Untag PVID Only

5520-VoIP-Test(config)#show vlan inter i 5
      Filter     Filter
     Untagged Unregistered
Port  Frames     Frames    PVID PRI    Tagging    Name
---- -------- ------------ ---- --- ------------- --------------
5    No       No           17   0   UntagPvidOnly Port 5

5520-VoIP-Test(config)#show vlan inter v 5
Port VLAN VLAN Name         VLAN VLAN Name         VLAN VLAN Name
---- ---- ----------------  ---- ----------------  ---- ----------------
5    17   Workstation       112  Voice_VLAN
---- ---- ----------------  ---- ----------------  ---- ----------------

5520-VoIP-Test(config)#show vlan inter v 1
Port VLAN VLAN Name         VLAN VLAN Name         VLAN VLAN Name
---- ---- ----------------  ---- ----------------  ---- ----------------
1    17   Workstation       20   NetworkMgmt       112  Voice_VLAN
---- ---- ----------------  ---- ----------------  ---- ----------------


Thanks!


Offline TankII

  • Hero Member
  • *****
  • Posts: 556
Re: ADAC configuration on 5520
« Reply #1 on: October 09, 2013, 11:34:56 AM »
Are your DHCP scope options also correctly set?
TankII

Offline TonsOfSteel

  • Jr. Member
  • **
  • Posts: 38
Re: ADAC configuration on 5520
« Reply #2 on: October 09, 2013, 12:27:00 PM »
Probably not. What options do I set?

Thanks!

Offline TonsOfSteel

  • Jr. Member
  • **
  • Posts: 38
Re: ADAC configuration on 5520
« Reply #3 on: October 09, 2013, 12:28:18 PM »
I should add that I do have a scope set up on the Voice Vlan. The Data Vlan Scope needs to be left to the PC connected to the Phone.

Thanks!


Offline Michael McNamara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • michaelfmcnamara
    • Michael McNamara
Re: ADAC configuration on 5520
« Reply #4 on: October 10, 2013, 10:46:09 PM »
Is the Astra IP phone capable and configured for LLDP-MED?
We've been helping network engineers, system administrators and technology professionals since June 2009.
If you've found this site useful or helpful, please help me spread the word. Link to us in your blog or homepage - Thanks!

Offline TankII

  • Hero Member
  • *****
  • Posts: 556
Re: ADAC configuration on 5520
« Reply #5 on: October 14, 2013, 12:51:56 PM »
This is what we use:
DHCP Options (Standard Option 242):
Voice VLAN:
mcipadd=10.X.X.X,httpsrvr=10.X.X.X,mcport=1719,httpdir=/avaya,vlantest=999
Data VLAN:
L2Q=1,L2QVLAN=XXX (example:  590)


TankII

Offline TonsOfSteel

  • Jr. Member
  • **
  • Posts: 38
Re: ADAC configuration on 5520
« Reply #6 on: October 16, 2013, 12:46:45 PM »
Thanks for your replies, I just got back in the office.

I did the adac config for the phone ports on the 5500, the DHCP Options on the Windows DHCP Server, and they are connecting to the Aastra Servers and functioning. I do see a DSCP of 46 traversing from my switch. I have not confirmed that it will pass throughout the network yet, that is in the queue.

The problem I have now is they installed the Aastra MX One system and connected it to our network claiming they wouldn't need QOS until we started using the VoIP Phones. Come to find out this was not true. These are 3 Aastra Linux SUSE appliances that have a PBX backbone consisting of switches that interconnect to each other through a 5532 Avaya switch. There is echo when an extension calls from one Aastra switch to another. These connections are on a different Vlan than the VoIP Phones. They are now live.
How would I prioritize the traffic coming from these three Aastra appliances?

Offline TankII

  • Hero Member
  • *****
  • Posts: 556
Re: ADAC configuration on 5520
« Reply #7 on: October 17, 2013, 02:28:41 PM »
From our internal Cheat Sheet:
Configuring QOS for any non ADAC capable device (Access Points, Voicemail Servers, etc)
Basic notes:  If the switch has ADAC already configured, do not add this trusted group to the Uplink as ADAC creates a trusted group by default.  Otherwise, add all Uplinks to the same group.
For a 5500/4500 series:
 
Again from "configure terminal"
 
The following command creates the group:
5520-48T-PWR(config)#qos if-group name VoWLAN class trusted   
 
No need to first remove them from their current assignment just move them to the newly created group:
**  int faste 1/1-30 (or whichever ports trust DSCP is needed)
Note:  If ADAC is enabled, the Uplinks will already be in a trusted group.  Do NOT make this change on any ports except the AP ports if ADAC is enabled on the switch.

 0-48T-PWR(config)#qos if-assign name VoWLAN

For ADAC enabled switches:
*******show qos agent should = 8 if not then qos agent 8 and reboot
 
That's it for the 5XXX/4XXX