• November 24, 2020, 09:49:17 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: 5510-48T FW & SW update problem  (Read 5000 times)

0 Members and 1 Guest are viewing this topic.

Offline Darklord

  • Rookie
  • **
  • Posts: 2
5510-48T FW & SW update problem
« on: November 26, 2013, 10:07:08 PM »
Hi,

I have 2 Nortel 5510-48T switch. I want to upgrade them to new firmware & software.

This is my switches configuration summary.

Module Description    BayStack 5510 - 48T 48 10/100/1000BaseTX plus 2 Overlapped GBIC slots
Firmware Version    v3.0.1.00
Software Version    v3.0.1.00
Manufacturing Date Code    20031216


I have in my hand ,

5.1.0
6.0
6.2.1 diags & software images


I tried to upgrade 5.1.0 , starting from diagnostic image update via TFTP.  I've succesfully upgrade it , but later when I tried to upload SW to switch , it says "invalid image"

One of my switch current config summary is;

Module Description    BayStack 5510 - 48T 48 10/100/1000BaseTX plus 2 Overlapped GBIC slots
Firmware Version    5.0.0.4
Software Version    v3.0.1.00
Manufacturing Date Code    20031216
Hardware Version    BS5510-48T HW:02


What should i do, any idea ?




Offline Dominik

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1564
    • Networkautobahn
Re: 5510-48T FW & SW update problem
« Reply #1 on: November 27, 2013, 03:01:52 AM »
The Problem is that the SW that you run on your switch is really old.
So you can not direct upgrade to e.g. 5.1. For SW 5.1 you need if I remeber it correct minimum SW 4.2.

So your upgrade path would look like 3.0.1 >> 4.0 >> 4.2 >> 5.1  >> 6.0 >> 6.2.1

Your switch will be 10 years old very soon (Manufacturing Date Code 2003 12 16) , cool that it still runs
after 10 years.

Cheers

 
Itīs always the networks fault!
networkautobahn.com

Offline TankII

  • Hero Member
  • *****
  • Posts: 556
Re: 5510-48T FW & SW update problem
« Reply #2 on: November 27, 2013, 11:28:04 AM »
got to get to 4.X, then...
5500 – 4.X --> 5.0.5.20 --> 50004 Diags/no reboot --> 5.1.0.14 --> 6.0.0.04 --> 60008 Diags without Reboot -->  6.1.1.16 -->  60010 diags without reboot --> 6.2.X

TankII

Offline CptnBlues63

  • Sr. Member
  • ****
  • Posts: 100
Re: 5510-48T FW & SW update problem
« Reply #3 on: November 27, 2013, 12:16:37 PM »
I've updated the majority of my 100+ 5500's from 4.2 to 6.2 and a couple to 6.3.

This is the path I followed on the advice of the people we bought the switches from:

4.2 >> 5.0 >> 6.0 >> 6.2/6.3

This has worked perfectly for me in over 100 switches.  I still have a couple running v4.2 that I can't presently update without an actual maintenance (shutdown) window as they're my server and DMZ stacks.


Dominik

Is there a reason you have to go from 4.0 to 4.2?

Offline Paul L

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 755
    • paulaleroux
    • Paul's Networking blog
Re: 5510-48T FW & SW update problem
« Reply #4 on: November 28, 2013, 08:11:40 PM »
just a warning.

at version v6 there were two different versions of the diag.

55x0_60006_diags.bin for 5500 series and 5000_60006_diag.bin for the 5600 series.   This was the only release with two separate diags.  after that version there was only one diag for the entire 5000 series family.

ACSS- Avaya Enterprise Routing Switch  #8

Offline Darklord

  • Rookie
  • **
  • Posts: 2
Re: 5510-48T FW & SW update problem
« Reply #5 on: November 28, 2013, 11:22:05 PM »
After your comments, finally I found 4.2.1 and successfully upgrade them

3.0.1 >> 4.2.1 >> 5.1  >> 6.0 >> 6.2.1 >> 6.2.4

4.2.1 was missing point :)

Thank you all,



Dominik,

Yes ,they are almost 10 years old. I also surprise that.But, I always clear their fans , keep them clean & stable temperature. But, I believe most important thing is Nortel produced really high quality product. Many thanks to who make 5500 series.

Cheers,











Offline Michael McNamara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • michaelfmcnamara
    • Michael McNamara
Re: 5510-48T FW & SW update problem
« Reply #6 on: December 03, 2013, 11:49:20 AM »
In early versions they recommended that you upgrade the agent code first, then the diagnostic code.

You might try to download the diagnostic code and then update the agent code followed by the diagnostic code again.
We've been helping network engineers, system administrators and technology professionals since June 2009.
If you've found this site useful or helpful, please help me spread the word. Link to us in your blog or homepage - Thanks!