• October 31, 2020, 03:31:15 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: Upgrade ws5100 ver 3  (Read 4460 times)

0 Members and 1 Guest are viewing this topic.

Offline mdl

  • Rookie
  • **
  • Posts: 8
Upgrade ws5100 ver 3
« on: June 28, 2013, 04:26:52 PM »
After loads of problems with a 5100 I am convinced there is an error with the hardware. To confirm this i want to try another unit.

I have another 5100 running firmware v2 so I am trying to update it to v3 as there are loads of problems with 2. I cant even get the gui working properly.

I have the v3 firmware but everytime I try and upload it to the switch with ftp i get a message after uploading. It verifies it and then says image file type must be 'data' deleting (whatever i have called the file)

I have tried to rename the file but always the same.

Any ideas .....

Thanks... Matt

oh. just a thought is it possible that the file is corrupt. I have some earlier firmware versions. i will try them as well.


Offline mdl

  • Rookie
  • **
  • Posts: 8
Re: Upgrade ws5100 ver 3
« Reply #1 on: June 30, 2013, 08:05:37 AM »
I still had no joy with the upgrade.

One thing  have not done is run th WS5100 Configuration Upgrade prior to uploading it to the switch.

Main reason is I dont have it or the pre upgrade script. As I am not bothered about the current settings I was hoping that I did not need it. No Motorola Contract so I am struggling to find it unless someone would be willing to share, Its not a firmware file so cant see an issue but if I am breaking rules apologies.

It does not seem to matter what extension is used either. I have seen a walkthrough by Micheal that has his file extensions completely different to a standard .img . I tried renaming then but still fails on the verify and deletes the file as it should be 'data'

back to the drawing board. Its getting frustrating now lol, Oh the joys of playing around. Should have just stuck to individual ap's and not a switch but now I have started I am determined to win.

Thanks

Matt


Offline wings

  • Rookie
  • **
  • Posts: 14
Re: Upgrade ws5100 ver 3
« Reply #2 on: June 30, 2013, 11:42:03 AM »
Hi,

You have to use the v2 to v3 upgrade image. When upgrading from version 2 to 3, the image name ends with .v2
You can find detailed instructions in the public available release notes to the image. For example at:

https:// docs.symbol.com/ReleaseNotes/WS5100_v3.3.5_Release_Notes_Web.pdf

Offline mdl

  • Rookie
  • **
  • Posts: 8
Re: Upgrade ws5100 ver 3
« Reply #3 on: June 30, 2013, 12:43:13 PM »
Hi Wings

Thanks, I just figured that out. I have managed to copy the .v2 file across and it has accepted it. I also have the scripts that i mentioned but again I should not need them hopefully.

I have managed it now I think,

i had a few problems trying to execute it but I think I have sorted it.

Its an older version 3 .v2 file but at least I should be able to work on it now. The stupid GUI on version 2 was a nightmare.

At least if I run into the same DHCP problems I know its me and not the switch.

the lack of documents on motorola,s part is astounding lol, I guess they want that contract. i think now i should have gone for equipment that has more help available especially when it s all new to me.

thanks

Matt

Offline md355

  • Jr. Member
  • **
  • Posts: 41
Re: Upgrade ws5100 ver 3
« Reply #4 on: July 02, 2013, 12:23:03 PM »
Hi to all !

Can anyone help me find for WS5100 firmware version 3.3.5.0-002 ?

I am trying to install AP300 built after 2010 (on a WS5100 with firmware 3.3.2.0) and these only work with the Isotope HW AP300 Patch, which I cannot install !!!

Apparently these newer AP300 need the patch (or a newer firmware) to work...

Many thanks !

MD355