• September 21, 2020, 02:10:16 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: broadcast-limit not working or what do i not do right?  (Read 4980 times)

0 Members and 1 Guest are viewing this topic.

Offline franklimstrand

  • Rookie
  • **
  • Posts: 4
broadcast-limit not working or what do i not do right?
« on: November 26, 2013, 09:32:05 AM »
Hi members

This is configured on my port:

interface C23
   broadcast-limit 30
   name "bofh"
   no power-over-ethernet
   exit

So on my linux workstation i run the (slightly modified) 'udp1' from the libnet (c library) package:
./udp1 -s 1.1.1.1.666 -d 255.255.255.255.1 -n 9999999999 -p thisismypayload

So with 'tcpdump' i see:

15:25:47.093263 18:03:73:e8:3a:d4 > ff:ff:ff:ff:ff:ff, ethertype IPv4 (0x0800), length 1510: (tos 0x0, ttl 64, id 242, offset 0, flags [none], proto UDP (17), length 1496, options (NOP,EOL))
    1.1.1.1.666 > 255.255.255.255.667: [udp sum ok] UDP, length 1448

This is an example of broadcast traffic right? With this pattern i can easily saturate my 1Gbps network link and a short test of this is "felt" in the network. I thought this should be limited so what do i not get?

With regards
Frank



Offline Michael McNamara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • michaelfmcnamara
    • Michael McNamara
Re: broadcast-limit not working or what do i not do right?
« Reply #1 on: November 27, 2013, 01:02:13 PM »
Hi Frank and welcome to the forums!

What HP switch are you referring to? What software release?

You'll still see frames flooding the network, but you should observe a reduction in the number of frames as compared to the number of frames you are injecting into the network.

Good Luck!
We've been helping network engineers, system administrators and technology professionals since June 2009.
If you've found this site useful or helpful, please help me spread the word. Link to us in your blog or homepage - Thanks!

Offline franklimstrand

  • Rookie
  • **
  • Posts: 4
Re: broadcast-limit not working or what do i not do right?
« Reply #2 on: November 28, 2013, 03:17:19 AM »
Hi Michael

Thank you for replying.

We are talking about a HP E5406 zl with:

Software revision  : K.15.09.0012
ROM Version        : K.15.28

I'll try to lower the limit to see what happens.

/FrankL

Offline franklimstrand

  • Rookie
  • **
  • Posts: 4
Re: broadcast-limit not working or what do i not do right?
« Reply #3 on: November 28, 2013, 04:35:49 AM »
Hi again

We tried setting the limit to 5% and then 1%, no help at all. Saturating the link is no problem. I wonder why the broadcast-limit setting does not work for us.

/FrankL

Offline franklimstrand

  • Rookie
  • **
  • Posts: 4
Re: broadcast-limit not working or what do i not do right?
« Reply #4 on: November 28, 2013, 07:48:09 AM »
Hi

This thread has the answer:

h30499.www3.hp.com/t5/ProCurve-ProVision-Based/broadcast-limit-not-working-or-what-do-i-not-do-right/m-p/6285605/highlight/false#M5032

/FrankL