• February 21, 2018, 11:38:50 AM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: cisco asa 5515x config help  (Read 3403 times)

0 Members and 1 Guest are viewing this topic.

Offline joelwood

  • Rookie
  • **
  • Posts: 3
cisco asa 5515x config help
« on: June 06, 2014, 01:49:19 PM »
What is keeping me from reaching internet? Config below. Thanks.

ASA Version 9.1(2)
!
hostname ciscoasa
enable password djMW8L3Na14L7q2L encrypted
names
!
interface GigabitEthernet0/0
 nameif OUTSIDE
 security-level 0
 ip address 10.9.251.2 255.255.255.0
!
interface GigabitEthernet0/1
 nameif INSIDE
 security-level 100
 ip address 10.9.250.2 255.255.255.0
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
<--- More --->
             
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
ftp mode passive
<--- More --->
             
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj-any
 subnet 0.0.0.0 0.0.0.0
pager lines 24
logging asdm informational
mtu management 1500
mtu OUTSIDE 1500
mtu INSIDE 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj-any
 nat (INSIDE,OUTSIDE) dynamic interface
route OUTSIDE 0.0.0.0 0.0.0.0 10.9.251.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
<--- More --->
             
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
 match default-inspection-traffic
<--- More --->
             
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
<--- More --->
             
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous prompt 1
Cryptochecksum:1298fcbdf92bf9b4c1ceeba8b7d4df4b
: end


Offline Flintstone

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 950
Re: cisco asa 5515x config help
« Reply #1 on: June 09, 2014, 04:45:20 AM »
Hi joelwood,

Have you tried setting up a 'capture' on the 'INSIDE' and 'OUTSIDE' interfaces to see if any traffic is coming in or out?

You can also use the 'packet-tracer' command to check that virtual traffic flows through your firewall correctly and is hitting your NAT rule?

CheerZ

Offline joelwood

  • Rookie
  • **
  • Posts: 3
Re: cisco asa 5515x config help
« Reply #2 on: June 09, 2014, 08:47:00 AM »
Hi joelwood,

Have you tried setting up a 'capture' on the 'INSIDE' and 'OUTSIDE' interfaces to see if any traffic is coming in or out?

You can also use the 'packet-tracer' command to check that virtual traffic flows through your firewall correctly and is hitting your NAT rule?

CheerZ

packet-tracer input inside icmp 10.9.250.2 0 0 8.8.8.8 detailed
Phase: 1
Type: ROUTE-LOOKUP
Subtype: input
Result: ALLOW
Config:
Additional Information:
in   0.0.0.0         0.0.0.0         OUTSIDE

Phase: 2
Type: ACCESS-LIST
Subtype:
Result: DROP
Config:
Implicit Rule
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0x7fff217fc8d0, priority=500, domain=permit, deny=true
   hits=3, user_data=0x6, cs_id=0x0, reverse, flags=0x0, protocol=0
   src ip/id=10.9.250.2, mask=255.255.255.255, port=0, tag=0
   dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, tag=0, dscp=0x0
   input_ifc=INSIDE, output_ifc=any

Result:
input-interface: INSIDE
<--- More --->
             
input-status: up
input-line-status: up
output-interface: OUTSIDE
output-status: up
output-line-status: up
Action: drop
Drop-reason: (acl-drop) Flow is denied by configured rule

Offline Flintstone

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 950
Re: cisco asa 5515x config help
« Reply #3 on: June 09, 2014, 09:06:58 AM »
Hi joelwood,

It looks like you need to setup some ACLs to allow the traffic through you firewall.  Once setup try using 'packet-tracer' again to confirm all is OK?

CheerZ