• September 25, 2017, 10:06:01 PM
Welcome, Guest. Please login or register. Registration is free.
Did you miss your activation email?

Author Topic: VDX and LACP  (Read 7095 times)

0 Members and 1 Guest are viewing this topic.

Offline Telair

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 953
VDX and LACP
« on: September 25, 2013, 05:38:17 PM »
I got to play on our VDX 6710 switches last night as we installed a bunch of servers.  Some servers needed to run LACP LAG's on their interfaces, or as Brocade says on VDX's, a "Port-channel".  Well, I now have a much better understanding of how they need to be created when the LAG is across two switches.  Once it is all created, it seems there are no changes allowed.  To make a change you need to delete the port-channel and then recreate it with the new parameters.  Ick!  If someone knows a better way, let me know!

Step 1 - Create the port-channel #10 on VDX switch A using VLAN 66 in access mode ( non-trunked ).

VDX6710-A# conf t
Entering configuration mode terminal
VDX6710-A(config)# interface Port-channel 10
VDX6710-A(config-Port-channel-10)# vlag ignore-split
VDX6710-A(config-Port-channel-10)# speed 1000
VDX6710-A(config-Port-channel-10)# description NetApp-VDX-LAG1
VDX6710-A(config-Port-channel-10)# switchport
VDX6710-A(config-Port-channel-10)# switchport mode access
VDX6710-A(config-Port-channel-10)# switchport access vlan 66
VDX6710-A(config-Port-channel-10)# no shutdown
VDX6710-A(config-Port-channel-10)# exit

Step 2 - Configure the switch port 11/0/23 for the port-channel and tell it to run a dynamic LAG on switch A.  Still in "config t" mode from the last commands we did.

VDX6710-A(config)# interface GigabitEthernet 11/0/23
VDX6710-A(conf-if-gi-11/0/23)# description NetApp3050_Port_e0c
VDX6710-A(conf-if-gi-11/0/23)# channel-group 10 mode active type standard
VDX6710-A(conf-if-gi-11/0/23)# lacp timeout long
VDX6710-A(conf-if-gi-11/0/23)# no shutdown

OK, that should have created the LAG on switch A.  Now to do switch B you just do steps 1 and 2 again ( with different port numbers if applicable ) and voila.  You have your dynamic LACP LAG using VLAN 66.

I wasted a fair bit of time trying to edit an existing port-channel LAG to no useful end.  If you need to make changes, just delete the port-channel ( VDX6710-A(config)# no interface Port-channel 10 ) and rebuild it.

To validate that your config is working ( checking that things work is what makes you an awesome network engineer ), you should:

1) Check the port-channel is working.

VDX6710-A#show interface Port-channel 10

Port-channel 10 is up, line protocol is up
Hardware is AGGREGATE, address is 0035.328d.da3e
Current address is 0035.328d.da3e
Description: NetApp-VDX-LAG1
Interface index (ifindex) is 677081373
Minimum number of links to bring Port-channel up is 1
MTU 2500 bytes
LineSpeed Actual : 1000 Mbit
Allowed Member Speed : 1000 Mbit

2) Check the port(s) in the port-channel are all working.

VDX6710-A# show interface gigabitethernet 11/0/23
GigabitEthernet 11/0/23 is up, line protocol is up (connected)
Hardware is Ethernet, address is 0005.8381.6db6
Current address is 0005.8381.6db6
Fixed Copper RJ45 Media Present
Description: NetApp3050_Port_e0c
Interface index (ifindex) is 90199943521
MTU 2500 bytes
LineSpeed : 1000 Mbit, Duplex: Full
Flowcontrol rx: off, tx: off


Then it's time to lock your workstation and head down to the pub for drinks.

P.S.  Don't forget to save your config after doing all that fine work.  Do your "copy running-config startup-config" before running off!
« Last Edit: September 25, 2013, 05:41:12 PM by Telair »